Closed Bug 96812 Opened 18 years ago Closed 16 years ago
IOutliner Box Object::Get Page Count() is misnamed
Shouldn't it be GetPageLength() or similar? The current name suggests it returns the number of pages in the outliner, not the number of rows in a page. The documentation gets it right, but it's confusing and it took a number of minutes looking at the source to clear it up.
Severity: minor → trivial
Status: UNCONFIRMED → NEW
Ever confirmed: true
hyatt, do you like suggested name ?
I'll get to this later, once I start formalizing outliner's interfaces in the XUL spec.
Assignee: trudelle → hyatt
Target Milestone: --- → mozilla1.0
Moving non nsbeta1+ XUL 1.0 bugs to mozilla1.2
Target Milestone: mozilla1.0.1 → mozilla1.2
Assignee: hyatt → varga
Status: ASSIGNED → NEW
Component: XP Toolkit/Widgets: XUL → XP Toolkit/Widgets: Trees
Status: NEW → ASSIGNED
Priority: -- → P3
Target Milestone: mozilla1.2alpha → mozilla1.7alpha
Fixed along with bug 221619. It's called GetPageLength() now.
fixed for real
Status: ASSIGNED → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
Component: XP Toolkit/Widgets: Trees → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.