Closed Bug 968141 Opened 8 years ago Closed 8 years ago

Remove nsPrinterFeatures, print.tmp.printerfeatures from GTK Printing

Categories

(Core :: Printing: Setup, defect)

All
Linux
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla30

People

(Reporter: dev_oskar, Assigned: dev_oskar)

Details

Attachments

(2 files)

The temporary prefs print.tmp.printerfeatures and nsPrinterFeatures should go.

The current GTK code won't use any of the print.tmp.printerfeatures, 
technical the PS Paper list is limited and incompatible to GTK code anyway.

The PageSetup and Print Dialog use native GTK Dialogs anyway.

Bug 136058 may be closed as well, it doesn't apply any more to current code.

As Bug 629500 is a massively step, this is start of a small step by step version to tidy the print system from old stuff, easier to follow.
Attachment #8370683 - Flags: review?(zackw)
Attachment #8370683 - Flags: review?(roc)
Assignee: nobody → dev_oskar
(In reply to Oskar Eisemuth from comment #0)
> The temporary prefs print.tmp.printerfeatures and nsPrinterFeatures should
> go.
> 
> The current GTK code won't use any of the print.tmp.printerfeatures, 
> technical the PS Paper list is limited and incompatible to GTK code anyway.

Thanks!

> Bug 136058 may be closed as well, it doesn't apply any more to current code.

Done. I have given you editbugs permission so you can do that sort of thing yourself.
The patch removes a remaining piece in PrintPreview of temporary pref, the print.whileInPrintPreview seems to be introduced only for PostScript GFX backend as workaround. However Print in PrintPreview was enabled by default with Bug 126802 a long time ago. So this patch removes print.whileInPrintPreview completly.
Attachment #8372197 - Flags: feedback?(roc)
Keywords: checkin-needed
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
https://hg.mozilla.org/mozilla-central/rev/9ea3501ac619
https://hg.mozilla.org/mozilla-central/rev/4153850acd1e
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla30
You need to log in before you can comment on or make changes to this bug.