Favicons in URL bar are not fetched after changing an option in settings menu

VERIFIED FIXED

Status

()

Firefox for Android
General
VERIFIED FIXED
5 years ago
2 years ago

People

(Reporter: u421692, Assigned: liuche)

Tracking

({regression})

Trunk
All
Android
regression
Points:
---

Firefox Tracking Flags

(firefox27 unaffected, firefox28 affected, firefox29 verified, firefox30 verified, fennec29+)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 8370725 [details]
device-2014-02-05-145626.png

Environment:
Device: Samsung Galaxy Tab (Android 4.0.4)
Build: Aurora 29.0a2 (2014-02-04)

Steps to reproduce:
1. Open a site(realitatea.net), wait for the site to load.
2. Open Settings menu, and change an option(e.g. Clear private data, or Plugins preference)
3. Exit Settings menu
4. Open another site(marketplace.firefox.com)

Expected result:
marketplace.firefox.com loads fine, the correct favicon is fetched

Actual result:
realitatea.net's favicon remains in the URL bar, until you restart Firefox(see attached screenshot)

Updated

5 years ago
tracking-fennec: --- → ?
Flags: needinfo?(chriskitching)
Keywords: regression, regressionwindow-wanted
Well, that's exciting.
Using the reported steps, I'm unable to reproduce this on my LG Nexus 4 (4.4.2) using Nightly (02/05, 30.0).
(In reply to Aaron Train [:aaronmt] from comment #2)
> Using the reported steps, I'm unable to reproduce this on my LG Nexus 4
> (4.4.2) using Nightly (02/05, 30.0).

I, too, cannot reproduce this on current nightly.
Very strange - why would this stop the LINK_FAVICON event being dispatched? Funky. And it's not even spinning!

Going to leave the flag in the vague hope I can find time to investigate this properly.
(In reply to Aaron Train [:aaronmt] from comment #2)
> Using the reported steps, I'm unable to reproduce this on my LG Nexus 4
> (4.4.2) using Nightly (02/05, 30.0).

Aaron: can you reproduce using Pop's env:

  Build: Aurora 29.0a2 (2014-02-04)

? I can't see why it would make a difference, but...
Nil difference; same steps, same build. ICS shenanigans? Pop, are you able to reproduce on Jellybean/Kitkat?
Reminds me of bug 939778; perhaps this is a tablet issue?
This looks like the same source issue as bug 939778 - favicon is not being updated on tablets after tapping a Settings header. Reproducible on Galaxy Tab 10.1 and Asus Transformer 1.

Any ideas on why the resource id for the favicon ImageView is changing, but the actual image being rendered is still the same?
(Reporter)

Comment 8

5 years ago
Tried to reproduce this issue on the following devices:

Samsung Galaxy Tab (Android 4.0.4) - REPRODUCING
Asus Transformer TF101 (Android 4.0.3) - REPRODUCING
Acer A500 (Android 3.2.1) - NOT REPRODUCING
Samsung Galaxy Tab 2 (Android 4.1.2) - NOT REPRODUCING
LG Nexus 4 (Android 4.4.2) - NOT REPRODUCING
ZTE Grand X IN (Android 4.0.4) - NOT REPRODUCING
HTC Desire HD (Android 2.3.4) - NOT REPRODUCING

From what it seems, this is tablet issue, reproducing only on ICS.
(Reporter)

Comment 9

5 years ago
2013-11-05 - good
2013-11-06 - bad
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=770de5942471&tochange=9ba3faa35c96

Bug 934658 may very well caused this issue. However by looking at the patch from Bug 934658, I wonder why honeycomb is not affected. Bug 939778 may also be affected by this.
(Reporter)

Updated

5 years ago
Keywords: regressionwindow-wanted
If this still affects Nightly, it shouldn't be throbber-related. More likely a lurking tablet bug.

(On that note, with the progress bar we should consider undoing Bug 934658...)
Chenxia - Let's backout bug 934658 and see what happens.
Assignee: nobody → liuche
tracking-fennec: ? → 29+
Created attachment 8372080 [details] [diff] [review]
Backout: backout for bug 934658

I'll have to test this when I get my hands on a tablet to see if it still causes the favicon problem.
Attachment #8372080 - Flags: review?(mark.finkle)
Flags: needinfo?(chriskitching)

Updated

5 years ago
Duplicate of this bug: 969302
Comment on attachment 8372080 [details] [diff] [review]
Backout: backout for bug 934658

Still interested to hear about your testing results too
Attachment #8372080 - Flags: review?(mark.finkle) → review+
Dammit sriram, this backout fixes this stupid favicon rendering bug! :)
(Reporter)

Comment 18

5 years ago
Verified this issue as fixed on latest Nightly(2014-02-09).
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Verified as fixed on
Builds:
29.0.1
30.0bs
31.0a2 (2014-05-27)
32.0a1 (2014-05-27)

Device: Alcatel One Touch (Android 4.1.2).

Also based on Mihai's Comment 18, I will mark this bug as verified fixed.
Status: RESOLVED → VERIFIED
status-firefox29: affected → verified
status-firefox30: affected → verified
You need to log in before you can comment on or make changes to this bug.