Google sees cookies disabled after clearing private datas

RESOLVED INVALID

Status

()

RESOLVED INVALID
5 years ago
2 years ago

People

(Reporter: paul.feher, Unassigned)

Tracking

29 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox28 affected, firefox29 affected, firefox30 affected, fennec-)

Details

(URL)

(Reporter)

Description

5 years ago
Build: Nightly 29.0a1 (2014-02-04), Aurora 29.0a2 (2014-02-04)
Device: LG Optimus 4x (4.1)

Steps to reproduce:
1. Try to log to gmail.com using wrong credentials
2. Save the credentials
3. Go to privacy and clear private data
4. Make sure you cookies are enabled
4. Go back and reload the page in the same tab from custom menu

Expected Results: 
gmail.com login page should be loaded 

Actual Results:
After pressing the reload button a notification message is displayed telling to resend information. After pressing the resend option an error massage shows up telling that the cookies are disabled.

Updated

5 years ago
tracking-fennec: --- → ?
After clearing data, we should display a toast. Did you wait to see the toast? If not, let's retest and make sure the the data has finished being cleared.
(Reporter)

Comment 2

5 years ago
The private data is cleared and the toast notification that says that the private data was cleared appeared long before the page was reloaded.
(In reply to Paul Feher from comment #2)
> The private data is cleared and the toast notification that says that the
> private data was cleared appeared long before the page was reloaded.

During triage we talked about this situation might just be "the way the web works". You logged into gmail, which sets a cookie, then cleared cookies. If gmail expects that cookie to exist, since it's logged in, but now it's gone, gmail might show an error or warning.

What happens on desktop?
tracking-fennec: ? → -
re comment #3
Flags: needinfo?(paul.feher)
(Reporter)

Comment 5

5 years ago
(In reply to Mark Finkle (:mfinkle) from comment #3)
> (In reply to Paul Feher from comment #2)
> > The private data is cleared and the toast notification that says that the
> > private data was cleared appeared long before the page was reloaded.
> 
> During triage we talked about this situation might just be "the way the web
> works". You logged into gmail, which sets a cookie, then cleared cookies. If
> gmail expects that cookie to exist, since it's logged in, but now it's gone,
> gmail might show an error or warning.
> 
> What happens on desktop?

On desktop I see the same behaviour.
Flags: needinfo?(paul.feher)
This was deemed invalid twice through two triages now.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.