Closed Bug 968756 Opened 6 years ago Closed 6 years ago

Light theme buttons don't have an "active" state

Categories

(DevTools :: Console, defect)

defect
Not set

Tracking

(firefox29 verified, firefox30 verified)

VERIFIED FIXED
Firefox 30
Tracking Status
firefox29 --- verified
firefox30 --- verified

People

(Reporter: paul, Assigned: bgrins)

References

Details

Attachments

(2 files)

Mousedown on a button (clear, js, …), the style of the button doesn't change.
I believe this is for all light theme buttons
Hardware: x86 → All
Summary: WebConsole buttons don't have an "active" state (white theme only) → Light theme buttons don't have an "active" state
Depends on: 957117
We are going to be working on a bigger restyle of toolbar buttons in Bug 952100, but this is an easy enough fix there isn't really a reason to wait for that.  The only issue is that to get enough contrast between normal, :hover, hover:active, and [checked], we may need to make the checked state a bit darker.

Right now:

normal: #f7f7f7
checked: #ddd
hover: #eee

to squeeze :hover:active in between #eee and #ddd isn't going to be very different from one or the other.
Attached image state-comparison.png
Assignee: nobody → bgrinstead
Status: NEW → ASSIGNED
What do you think?
Attachment #8371454 - Flags: review?(paul)
Attachment #8371454 - Flags: review?(paul) → review+
https://hg.mozilla.org/mozilla-central/rev/6c1d05889bc8
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 30
Comment on attachment 8371454 [details] [diff] [review]
light-theme-button-states.patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 957117
User impact if declined: Buttons in DevTools light theme will not have an active state
Testing completed (on m-c, etc.): On m-c since 2-06
Risk to taking this patch (and alternatives if risky): Low risk - CSS only change in DevTools
String or IDL/UUID changes made by this patch:
Attachment #8371454 - Flags: approval-mozilla-aurora?
Attachment #8371454 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified with latest builds of Nightly and Aurora
Status: RESOLVED → VERIFIED
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.