Closed Bug 968809 Opened 6 years ago Closed 4 years ago

VP9 videos that autoplay when opened are played the first 1-2 seconds at a lower luminosity.

Categories

(Core :: Audio/Video: Playback, defect)

28 Branch
defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: VarCat, Unassigned)

References

Details

Environment:

Beta FF 28 
Build Id: 20140205162153

STR:

1. Open the following video https://moztrap.mozilla.org/media/attachments/2014/01/22/vp9cake.webm

Expected:
The video autoplays smoothly for the entire duration

Actual:
The luminosity of the video is lower on the first 1-2 seconds.

Note:
The bug is not reproducible if you replay the video on the same page.

I managed to reproduce the issue using 

FF Aurora 28
Build id:20131216004006 

so this issue is not a regression.
I can reproduce with today's nightly. I can also reproduce sometimes if I load the video in a html wrapper with both 'autoplay' and 'controls' attributes, but in that case I also get a loading spinner.

Therefore it looks like the lower luminosity is caused by the transition intended to mark the transition to canplaythrough, etc. So the bug is either than we shouldn't show the transition when we start playing so quickly, or we're not showing the spinner on the videodocument for some reason.
Component: Audio/Video → Audio/Video: Playback
Ralph - can you still reproduce this issue?
Flags: needinfo?(giles)
I can't reproduce. The link in the description doesn't play at all because we reject the bad muxing, but the replacement in-tree plays fine.
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(giles)
Resolution: --- → FIXED
I have seen this.

This is due to how we present paused video element. The image is made to look slightly darker.

When you resume, the picture progressively lighten up (over about 1s).

I'm not a fan of it, but it's a UI fanciness.

This effect is seen when you simply load a paused video element, and then start playing it
Resolution: FIXED → INVALID
You need to log in before you can comment on or make changes to this bug.