Closed Bug 968814 Opened 6 years ago Closed 6 years ago

Frames added in Toolbar have scrollbars if they have any content in them

Categories

(Add-on SDK Graveyard :: General, defect, P3)

defect

Tracking

(firefox29 fixed)

RESOLVED FIXED
Tracking Status
firefox29 --- fixed

People

(Reporter: zer0, Unassigned)

References

Details

Attachments

(2 files)

Priority: -- → P3
Duplicate of this bug: 972935
from bug 972935, it looks like this is a problem across platforms..
OS: Mac OS X → All
Hardware: x86 → All
Attached file Fix
Attachment #8378623 - Flags: review?(zer0)
Commit pushed to master at https://github.com/mozilla/addon-sdk

https://github.com/mozilla/addon-sdk/commit/42aa9919e109921be63c311af4c0eef2f0b5562f
Merge pull request #1407 from Gozala/bug/toolbar-scroll

fix Bug 968814 - Fix undesired scrollbars in toolbars. r=@ZER0
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Attachment #8378623 - Flags: review?(zer0) → review+
Attached patch patchSplinter Review
[Approval Request Comment]
Bug caused by (feature/regressing bug #): New SDK toolbars
User impact if declined: On some older OSX platforms the toolbar will show a small scrollbar
Testing completed (on m-c, etc.): On Nightly for over a week, little add-on code uses this though so probably little real-world testing.
Risk to taking this patch (and alternatives if risky): The change is just some styling corrections, very low risk.
String or IDL/UUID changes made by this patch: None
Attachment #8384939 - Flags: approval-mozilla-aurora?
Attachment #8384939 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.