Firefox 28 beta 1 closes when switching from Desktop to Metro mode

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: bogdan_maris, Unassigned)

Tracking

Trunk
x86
Windows 8

Firefox Tracking Flags

(Not tracked)

Details

Reproducible on:
Firefox 28 beta 1 (Build ID:20140205162153)
Mozilla/5.0 (Windows NT 6.2; rv:28.0) Gecko/20100101 Firefox/28.0
latest Aurora 29 (Build ID:20140206004003)
Mozilla/5.0 (Windows NT 6.2; rv:29.0) Gecko/20100101 Firefox/29.0
latest Nightly 30 (Build ID:20140206030201)
Mozilla/5.0 (Windows NT 6.2; rv:30.0) Gecko/20100101 Firefox/30.0

STR:
1. Launch Firefox with a clean profile.
2. Make Firefox the default browser.
3. Click the 'Relaunch in Firefox for Windows 8 Touch' menu item

Expected result: The browser switches from Desktop to Metro mode.
Actual result: The browser is closed.

Notes:
1. No process active in Task Manager.
2. Chrome is the default browser before installing Firefox.
3. When I click the 'Relaunch in Firefox for Windows 8 Touch', also the console closes (both web console and the one opened from terminal).
4. Couldn't reproduce on another Windows 8 32bit machine.
5. On Windows 8.1 64-bit the attempt of relaunching Firefox in Windows 8 touch-mode is also failing. The Firefox logo screen is displayed for a second, followed by a forced return to Windows' Start Menu. Default Programs and file type associations are correctly configured from Control Panel > Default Programs, but with no success. It's also worth mentioning that sometimes, a suspended Firefox process is displayed in the Details tab of Task Manager and in some other cases, the attempt of relaunching Fx in touch mode results in the actual relaunch of Nightly in touch mode instead. This behavior is encountered for multiple localizations. I tried to replicate this issue on a different machine with Windows 8.1 64-bit and also on a Microsoft Surface Pro 2, but it did not reproduce.
6. I'll try to reproduce this issue again on clean installs, using both of the machines where this test failed.
hmm, not seeing this in 02-06 aurora, will test latest mc tip as well.
(In reply to Bogdan Maris, QA [:bogdan_maris] from comment #0)
> 1. No process active in Task Manager.
> 2. Chrome is the default browser before installing Firefox.
> 3. When I click the 'Relaunch in Firefox for Windows 8 Touch', also the
> console closes (both web console and the one opened from terminal).

Not sure I understand what this means. Maybe we are running into an issue with the test harness we use?

I've also tested mc tip, no issues.
Blocks: 838081
Whiteboard: [triage] p=0

Comment 3

5 years ago
Couldn't reproduce this issue on the same machines as in comment 1 and a clean Windows install; tried several attempts: latest Nightly, Aurora and Firefox 28 beta 1 successfully switch from Desktop to Metro mode. Looks like it was an OS issue.
Closing as WFM.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
No longer blocks: 838081
Whiteboard: [triage] p=0
You need to log in before you can comment on or make changes to this bug.