Line gets duplicate in e.me

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Everything.me
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: Ioana Chiorean, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v1.3 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8371547 [details]
screenshot

Device: Geon from Geeksphone
OS: Boot3Gecko 1.3.0.0-prerelease 

Steps to reproduce:
1. Have previously installed Line 
2. Update Line (Monday (02/03))

Actual results:
- Line icon got duplicated in e.me

Expected Results:
- Line should be present only once in e.me

Note 
- please see the attached screenshot
This has been resolved on master as part of a visual refresh Patryk lead. Bug 944068.
Wasn't meant for landing on v1.3 afaik.
I'm sorry, my reply was meant for a different Bug.

Amir, can you reproduce this?
Flags: needinfo?(amirn)

Comment 3

4 years ago
Do you know how to simulate an app update?
Flags: needinfo?(amirn)
If this happens due to app update then it's probably a mozApps issue as it supplies duplicates.
Cristian, do you know who should be assigned to this?
Flags: needinfo?(crdlc)
No idea, but I would like to know if there are duplicated line's in grid too
Flags: needinfo?(crdlc)
Vivien, do you know who we should turn to regarding Comment #4?

Updated

4 years ago
Flags: needinfo?(21)
(In reply to Ran Ben Aharon (Everything.me) from comment #6)
> Vivien, do you know who we should turn to regarding Comment #4?

How is this part of the screen rendered ? Does the results comes from the homescreen directly or do they come from the mozapps database ?
Flags: needinfo?(21) → needinfo?(ran)
From GridManager.getApps().
Should I involve crdlc?
Flags: needinfo?(ran)
I would like to know if there are duplicated line apps in grid too or not
It's all speculation till we reproduce. Anyone know how?
(Reporter)

Comment 11

4 years ago
Hi, 
a fellow mozillian entered Bug 976858 on 1.4. 
I do not have 1.4 now to try to reproduce it.. but maybe it is helpful..

Regards,
`ioana
Blocks: 976858
Thank you Ioana but that bug is unrelated to this issue
(Reporter)

Updated

4 years ago
No longer blocks: 976858
I'd like to try and reproduce this with the new collection app and vertical homescreen, but still don't know how to simulate an app update.

Jason, can you help?
Flags: needinfo?(jsmith)
Johan was planning on doing testing of app updates during our test run this week, so let me switch the needinfo to him to look into this.
Flags: needinfo?(jsmith) → needinfo?(jlorenzo)
To do an app update on a dummy packaged app:
1. Get one of the manifest on http://mozilla.github.io/qa-testcase-data/webapi/apps/ and host it on your own HTTP server
2. Install the app by pointing to your self-hosted manifest via you browser
3. To simulate an app update, in the the mini-manifest, modify at least:
"version": "1.0" to "version": "2.0"
4. Check for new version and wait until the notification pop.
5. Update the app.

Feel free to ask further questions.
Flags: needinfo?(jlorenzo)
(In reply to Jason Smith [:jsmith] from comment #14)
> Johan was planning on doing testing of app updates during our test run this
> week, so let me switch the needinfo to him to look into this.

Johan, are you able to reproduce on v2.0 branch?
Flags: needinfo?(jlorenzo)
I looked into it. To test it properly, we need to use the marketplace dev app which is currently not present in 2.0 eng build (bug 1011016).
We can use the stage marketplace as a workaround, but the update is currently broken (bug 1059546).

Hence, I leave the needinfo until one of these 2 bugs is fixed.
Flags: needinfo?(jlorenzo)
Flags: needinfo?(jlorenzo)
I am still not able to use Marketplace properly. I can't install LINE on the Stage marketplace.
> I/Stage   ( 1584): Content JS LOG: [iframe-install] App download error: INSTALL_FROM_DENIED 

This issue doesn't appear with other app like 2048 or Soundcloud.

I think this current bug is a minor issue hard to reproduce. It was filed for 1.3 and we are now after 2.1 Feature Complete. Nobody filed a dupe against this bug since then. I guess it's safe to close this bug now and to reopen another one if this issue occurs again.

What do you think, Ran?
Flags: needinfo?(jlorenzo) → needinfo?(ran)
I agree
Flags: needinfo?(ran)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.