[4.xP] Text input element should be in monospace font

VERIFIED DUPLICATE of bug 17303

Status

()

Core
CSS Parsing and Computation
P3
normal
VERIFIED DUPLICATE of bug 17303
19 years ago
18 years ago

People

(Reporter: dbaron, Assigned: Pierre Saslawsky)

Tracking

Trunk
Other
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Text input elements should be in a monospace font, as they are in 4.x.  This
can be fixed with the following rules in ua.css (I have them in mine right
now):

input[type] { font-family: inherit; }
textarea, input, input[type=text], input[type=password] {
        font-family: monospace;
        }

The unfortunate complexity is due to the acceptance of input elements without a
type.  I'm not sure if this is legal HTML or not, but...

Comment 1

19 years ago
Pushing off non-beta 1 issues
Summary: [4.xP]Text input element should be in monospace font → [4.xP] Text input element should be in monospace font
Why should <input type=text> be in monospace? I agree for multiline controls,
but with single line text inputs there is nothing to align with particularly,
so it would appear to me that the point is moot.

For single line text controls, IE5 uses a sans-serif proportional font, which
IMHO looks much nicer.
(Assignee)

Comment 3

18 years ago
Reassigning peterl's bugs to myself.
(Assignee)

Comment 4

18 years ago
Accepting peterl's bugs that have a Target Milestone
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 5

18 years ago
It was fixed a while back, although not exactly as shown above: textarea and
input[type=text] use 'font-family:-moz-fixed'.

Closing as duplicate of 17303.


*** This bug has been marked as a duplicate of 17303 ***

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 6

18 years ago
Verified dup of #17303
You need to log in before you can comment on or make changes to this bug.