WebGL hang on OS X on http://www.gootechnologies.com/

RESOLVED DUPLICATE of bug 947227

Status

()

RESOLVED DUPLICATE of bug 947227
5 years ago
3 years ago

People

(Reporter: jrmuizel, Unassigned)

Tracking

({qawanted})

unspecified
x86
Mac OS X
qawanted
Points:
---

Firefox Tracking Flags

(firefox30-)

Details

(Reporter)

Description

5 years ago
STR:
- load http://www.gootechnologies.com/
- scroll around for a while
- the browser hangs

Here's a stack on the client side:
    frame #0: 0x00007fff90f0f716 libsystem_kernel.dylib`__psynch_cvwait + 10
    frame #1: 0x00007fff90f52c3b libsystem_pthread.dylib`_pthread_cond_wait + 727
    frame #2: 0x00000001005146e9 libnss3.dylib`PR_WaitCondVar + 105
    frame #3: 0x00000001017575e1 XUL`mozilla::gfx::SurfaceStream_TripleBuffer_Async::WaitForCompositor() + 177
    frame #4: 0x0000000101757030 XUL`mozilla::gfx::SurfaceStream_TripleBuffer::SwapProducer(mozilla::gfx::SurfaceFactory*, mozilla::gfx::IntSizeTyped<mozilla::gfx::UnknownUnits> const&) + 384
    frame #5: 0x000000010174d4b9 XUL`mozilla::gl::GLScreenBuffer::Swap(mozilla::gfx::IntSizeTyped<mozilla::gfx::UnknownUnits> const&) + 41
    frame #6: 0x000000010174593d XUL`mozilla::gl::GLContext::PublishFrame() + 45
    frame #7: 0x000000010228f47e XUL`mozilla::WebGLContext::PresentScreenBuffer() + 94
    frame #8: 0x0000000102295229 XUL`mozilla::WebGLContextUserData::PreTransactionCallback(void*) + 41
    frame #9: 0x00000001017cbf8b XUL`mozilla::layers::ClientCanvasLayer::RenderLayer() + 475
    frame #10: 0x00000001017d75ff XUL`mozilla::layers::ClientContainerLayer::RenderLayer() + 879
    frame #11: 0x00000001017d75ff XUL`mozilla::layers::ClientContainerLayer::RenderLayer() + 879


and a stack on the compositor:

* thread #24: tid = 0x24e8ff, 0x00007fff90f0f716 libsystem_kernel.dylib`__psynch_cvwait + 10, name = 'Compositor
    frame #0: 0x00007fff90f0f716 libsystem_kernel.dylib`__psynch_cvwait + 10
    frame #1: 0x00007fff90f52c3b libsystem_pthread.dylib`_pthread_cond_wait + 727
    frame #2: 0x00000001012b5da8 XUL`base::WaitableEvent::TimedWait(base::TimeDelta const&) + 360
    frame #3: 0x00000001012b5f59 XUL`base::WaitableEvent::Wait() + 25
    frame #4: 0x00000001012cc25c XUL`base::MessagePumpDefault::Run(base::MessagePump::Delegate*) + 364
    frame #5: 0x00000001012c5e5e XUL`MessageLoop::Run() + 78
    frame #6: 0x00000001012d305c XUL`base::Thread::ThreadMain() + 156
(Reporter)

Updated

5 years ago
tracking-firefox30: --- → ?
Keywords: regressionwindow-wanted
I'm unable to reproduce this I tried it on the release of nightly when you originally posted this and now. Are your STR exact?
Flags: needinfo?(jmuizelaar)
Keywords: qawanted
(Reporter)

Comment 2

5 years ago
I think this was fixed by another bug
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(jmuizelaar)
Resolution: --- → DUPLICATE
Duplicate of bug: 947227
tracking-firefox30: ? → -
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.