Closed Bug 96912 Opened 19 years ago Closed 19 years ago

does not send Referer headers to https URLs

Categories

(Core :: Networking: HTTP, defect)

x86
Linux
defect
Not set
major

Tracking

()

VERIFIED DUPLICATE of bug 89995

People

(Reporter: peterw, Assigned: neeti)

Details

From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.2.19-6.2.1 i686)
BuildID:    20010801

Mozilla 0.9.3 does not seem to send Referer request headers when
making https requests, *even to the same server*. E.G. I have a
page with code like
<form method="post" action="/path/to/app"
enctype="application/x-www-form-urlencoded">

Mozilla 0.9.3 does not send a Referer header when posting the data.

Note Mozilla 0.9.3 *does* send the Referer header to http sites; the problem
seems limited to https:// URLs.

Previous versions of Mozilla (most recently tested: 0.9.1) did send the Referer.

This breaks some of my Web apps.


Reproducible: Always
Steps to Reproduce:
1. Go to an https URL
2. Follow a link to another page on that https site
3. Note the lack of Referer header (check https logs, use CGI for 2nd page,
etc.)

Actual Results:  The second page did not see a client Referer request header.

Expected Results:  The second page should have seen a Referer header with the
URL of the first page.
fixed in recent nightly builds.
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → INVALID
Changing to be a dup of bug 89995 for future reference.  It's confusing to see a
lot of bugs marked "invalid" on a list of bugs involving referer and https.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

*** This bug has been marked as a duplicate of 89995 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago19 years ago
Resolution: --- → DUPLICATE
Verified dupe.
Status: RESOLVED → VERIFIED
QA Contact: tever → junruh
You need to log in before you can comment on or make changes to this bug.