Closed Bug 969170 Opened 9 years ago Closed 9 years ago

[B2G][l10n]Buttons displayed in prompt after long pressing an E.Me search result is untranslated.

Categories

(Firefox OS Graveyard :: Gaia::Everything.me, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:1.3+, b2g-v1.3 verified, b2g-v1.3T fixed, b2g-v1.4 verified)

RESOLVED FIXED
blocking-b2g 1.3+
Tracking Status
b2g-v1.3 --- verified
b2g-v1.3T --- fixed
b2g-v1.4 --- verified

People

(Reporter: rkuhlman, Assigned: crdlc)

References

Details

(Keywords: late-l10n, Whiteboard: LocRun1.3)

Attachments

(9 files)

Attached file EnglishButtonText.txt
After long pressing an E.Me search result, a prompt appears asking whether the user would like to 'Add to top of collection', or 'Save to Homescreen'. These buttons always display in English. This happens in all non English languages.

Repro Steps:
1) Updated Buri to BuildID: 20140206004002
2) Set device to a non English language.
3) Launch E.Me and search for 'Social'.
4) Long press 'Facebook'.
5) Observe prompt.

Actual:
Buttons for 'Add to top of collection' and 'Save to homescreen' are displayed in English.

Expected:
Button text is displayed in device language.

Environmental Variables:
Device: Buri v1.3 Moz RIL
BuildID: 20140206004002
Gaia: 467ef8c9145d9a57d35b0619db541d23b522b958
Gecko: a1fa925c40c2
Version: 28.0
Firmware Version: v1.2-device.cfg

Notes:

Repro frequency: 100%
See attached screenshot and logcat.
Attached image EnglishButtons.png
Issue does not occur in v1.2
Environmental Variables:
Device: Buri v1.2 COM RIL
BuildID: 20140203004002
Gaia: 539a25e1887b902b8b25038c547048e691bd97f6
Gecko: 9250d1b1cb6e
Version: 26.0
RIL Version:v1.2-device.cfg
Attached image 2014-02-07-08-06-26.png
I'm not sure I understand this bug.

For sure this is not a bug in the first time experience module.

Having said that, If I follow the instructions this is the screen I get: completely localized, completely different though.
Can you recheck you results here?
Flags: needinfo?(rkuhlman)
Try again in today's (02/07) build.
Environmental Variables:
Device: Buri v1.3 Moz RIL
BuildID: 20140207004002
Gaia: 1527d1e450364e383eeb95ff898dca2042e2b4b5
Gecko: 0a6d83aabb02
Version: 28.0
Firmware Version: v1.2-device.cfg

The issue occurs for every language on my device with this build.

The screenshot you provided is the format that was used in FxOS 1.2. I went through every language in yesterday's(02/06) build and there were a few languages that still displayed the old format. In today's build all of these languages have been updated and the current format is displayed with the additional option to add to top of collection.
Flags: needinfo?(rkuhlman)
I don't think that answers the question clearly here. What screenshot are seeing right now? Francesco's screenshot or your original screenshot?
Flags: needinfo?(rkuhlman)
In today's build I always see the screenshot that I provided. The screen provided by Francesco is from v1.2.

Apparently in the 02/06 build, some languages had not yet been updated to display the newer screen with additional options. The buttons are displayed in English for all languages.
Flags: needinfo?(rkuhlman)
Okay - that makes sense. Francesco's build is testing a build without collections (not 1.3), where as yours is (1.3), which is why the screenshots are different.

We've got an untranslated UI then, so noming to block.
blocking-b2g: --- → 1.3?
Component: Gaia::First Time Experience → Gaia::Homescreen
Keywords: late-l10n
Component: Gaia::Homescreen → Gaia::Everything.me
Can you provide a screenshot of what you are seeing on your device for comparison?
Flags: needinfo?(crdlc)
Attached image french contextmenu.png
I am seeing this screenshot and the code is ready to translate correctly in v1.3. I don't know if there are a problem with locales in that build what you are using,.. but the code is done. I think that there is not a bug in homescreen app code. I have never said "pretty sure" just in case :) but the code looks good to me
Flags: needinfo?(crdlc)
Attached image french contextmenu.png
This picture is with a 1.3 build today, the previous one was the homescreen v1.3 in gaia running in my device with master build
Okay - that implies the UI is possible to translate then.

rkuhlman - What locales are currently not translated here then? French appears to work, so this isn't untranslated in all possible locales.
blocking-b2g: 1.3? → ---
Flags: needinfo?(rkuhlman)
QA Contact: pfield
Attached file log.txt
Issue does not occur when the user searches through the E.Me bar and searches social however, if the user searches through the 'Social collection' and uses the above (Comment 0) STR, the issue will appear regardless of language.

To clarify this issue appears as described in comment zero if the user searches facebook using the premade social collection. (Even in french.)

Attaching 
-logcat (Searching social with collection and searching with E.Me bar.)
-Screenshots (Of issue occuring with social collection, and of issue not occuring with E.Me bar)
-New STR (Next comment)
Attached image SearchViaCollection.png
NEW STR - - -

Repro Steps:
1) Updated Buri to BuildID: 20140210004002
2) Set device to a non English language. (Example español)
3) Launch E.Me and search for 'Social'.
4) Long press 'Facebook'.
5) Exit E.Me and select 'Social' collection.
6) Long Press on 'Facebook'.
7) observe the text.

Actual:
Buttons for 'Add to top of collection' and 'Save to homescreen' are displayed in English when the user searchs via the 'social' collection.

Expected:
Button text is displayed in device language.
Attached image SearchViaEme.png
Environmental Variables:
Device: buri 1.3 moz
BuildID: 20140210004002
Gaia: 5c8416fb1ea4a27f172ee6386ab3c19135448506
Gecko: 9c9382f433c0
Version: 28.0
Firmware Version: v1.2-device.cfg
Flags: needinfo?(rkuhlman)
Assignee: nobody → crdlc
Status: NEW → ASSIGNED
Attached file Patch v1
Attachment #8373935 - Flags: review?(ran)
Attachment #8373935 - Flags: review?(ran) → review?(amirn)
Comment on attachment 8373935 [details]
Patch v1

r+. Thanks Cristian.
Attachment #8373935 - Flags: review?(amirn) → review+
Merged in master:

https://github.com/crdlc/gaia/commit/0f1503eac4682c4409b0dee0a4220eadb4f67daa
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
blocking-b2g: --- → 1.3?
blocking-b2g: 1.3? → 1.3+
Uplifted bf4e7addd174a222264f18c02795dd6d755b9d3c to:
v1.3: f934b92252938f649b338e95d5d148e9ee263669
Which bug regressed this?

Also, I'm having a hard time figuring out how the review chain here ends up with a peer or owner on https://wiki.mozilla.org/Modules/FirefoxOS. I learned on the 1.3 feedback call that that was supposed to be the case.
(In reply to Axel Hecht [:Pike] from comment #21)
> Which bug regressed this?

There was not any regression, that UI was not localized :( 

> 
> Also, I'm having a hard time figuring out how the review chain here ends up
> with a peer or owner on https://wiki.mozilla.org/Modules/FirefoxOS. I
> learned on the 1.3 feedback call that that was supposed to be the case.
Blocks: 938423
Verified-fixed on latest 1.3 Moz RIL
Gaia      6194def5ceed3f4b9bc9de0ea2c11661cd439a27                      
Gecko     https://hg.mozilla.org/releases/mozilla-b2g28_v1_3/rev/9368fd13bfa6     
BuildID   20140313004002                                                 
Version   28.0   

and also Verified fixed on latest 1.4 Moz RIL
Gaia      ec28d9dcf57ca8da142f9f2fea33bc288b76ed59                      
Gecko     https://hg.mozilla.org/mozilla-central/rev/46041cc216fd       
BuildID   20140313040203                                                
Version   30.0a1
You need to log in before you can comment on or make changes to this bug.