Linux: First Run Tour: Menu panel doesn't stay attached to anchor when you resize the window

RESOLVED DUPLICATE of bug 972566

Status

()

defect
RESOLVED DUPLICATE of bug 972566
6 years ago
5 years ago

People

(Reporter: VarCat, Unassigned)

Tracking

29 Branch
x86
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Australis:P3-])

Reporter

Description

6 years ago
Environment used:

FF 29
User Agent:Mozilla/5.0 (X11; Linux i686; rv:29.0) Gecko/20100101 Firefox/29.0
Build Id:20140207004002
OS: Ubuntu 12.10 x32 

STR:



1. Start the First Run Tour from https://www.mozilla.org/en-US/firefox/29.0a2/whatsnew/.
2. On the first step the Menu Panel is opened.
3. Resize the Firefox window.

Expected:
You can't resize the window because the focus is on the menu panel( this is the behavior on the rest of the pages with Australis)

Actual:
You are allowed to resize and the Menu Panel and the highlight remain on the same spot even if the window was moved due to resizing.
Reporter

Comment 1

6 years ago
I'll check next week to see if this is a regression or not.
The good news is that we didn't run the tour on Linux for Aurora yet.

Unfortunately I'm having a hard time understanding why you expect that you shouldn't be able to resize the window? It is true that outside the tour when you go to resize the window, the menu panel normally closes but during the tour we intentionally keep it open so that, for example, clicks on the webpage don't make the panel disappear only to have the page re-open it every time.

> and the Menu Panel and the highlight remain on the same spot even if the window was moved due to resizing.

This is not expected. They should follow the window albeit sometimes with a big lag.
I concur with the last comment. I presume the same thing true when it's a menu that's open.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → INVALID
Reporter

Comment 4

5 years ago
From comment 2 my understanding is that the fact that the menu panel remains open even if you click on the page is expect behavior. 
But the issue that the Menu Panel and the highlight remain on the same spot even if the window was moved due to resizing is still a bug . And this bug is not reproducible outside of UI Tour because you can't resize the Fx window without first focusing the window and outside of UI Tour the menu panel will close when you focus the window. The bug is somewhat similar with bug 972566 the difference being that under Ubuntu the issue is reproducible 100% of the time.
(In reply to Catalin Varga [QA][:VarCat] from comment #4)
> From comment 2 my understanding is that the fact that the menu panel remains
> open even if you click on the page is expect behavior. 
> But the issue that the Menu Panel and the highlight remain on the same spot
> even if the window was moved due to resizing is still a bug . And this bug
> is not reproducible outside of UI Tour because you can't resize the Fx
> window without first focusing the window and outside of UI Tour the menu
> panel will close when you focus the window. The bug is somewhat similar with
> bug 972566 the difference being that under Ubuntu the issue is reproducible
> 100% of the time.

If a webpage resizes the browser window while the panel is open, I suspect the same issue would occur even without the UI Tour (unless that also autohides the menupanel under normal circumstances, I'm not sure).

I expect that the panel not being anchored correctly (ie not following the anchor when its position changes due to a resize) is a Linux-specific issue. :-(
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Summary: First Run Tour: Menu Panel is opened on the first step and the focus is changed to the web page allowing for resizing of the page . → Linux: First Run Tour: Menu panel doesn't stay attached to anchor when you resize the window
(P3- because the breakage isn't major, few people will do this, even fewer people are on Linux; Matt, please adjust if you disagree and/or I've missed something)
Whiteboard: [Australis:P3-]
Lets dupe this to bug 972566 then since comment 0 prescribes not allowing resizes which I don't agree with.
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 972566
You need to log in before you can comment on or make changes to this bug.