bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Script closes opener without permision

RESOLVED DUPLICATE of bug 32571

Status

()

Core
DOM: Core & HTML
RESOLVED DUPLICATE of bug 32571
17 years ago
17 years ago

People

(Reporter: bht237, Assigned: jst)

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
The attached testcase shows that a simple script can close the main browser 
window without asking the user for permission.
In comparison, Internet Explorer shows a confirmation dialog.

I am suggesting to remove this "feature" urgently because of the following:

Users often install third party products such as pop-up killers to control 
browser behaviour if not sufficiently supported as in this case of closing the 
main window.

Such third party products usually cause more maintenance and help desk issues 
for well-behaved sites than what they are worth in the exceptional cases. In 
addition, users will feel uncomfortable visiting sites that use full screen 
new windows or even small pop-ups.

We plan to use pop-ups to collect optional data for data entry forms. The last 
thing we want is that the users turn them off because of browser instability.
(Reporter)

Comment 1

17 years ago
Created attachment 47107 [details]
Single HTML file opens new window and closes own window

Comment 2

17 years ago

*** This bug has been marked as a duplicate of 32571 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.