Closed Bug 969661 Opened 6 years ago Closed 6 years ago

Character Encoding widget stays disabled if you move it to the toolbar from the menu panel while it is disabled

Categories

(Firefox :: Toolbars and Customization, defect)

29 Branch
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 30
Tracking Status
firefox29 --- verified
firefox30 --- verified

People

(Reporter: jaws, Assigned: Gijs)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [Australis:P4])

Attachments

(1 file, 1 obsolete file)

STR:
Enter customization mode
Move the Character Encoding widget to the panel
Go to about:home
Open the panel
The character encoding widget should be disabled
Right-click on it and choose "Move to toolbar"
Navigate to www.mozilla.org

ER:
The button in the toolbar becomes enabled.

AR:
The button in the toolbar stays disabled.

Workaround: While on mozilla.org, right-click and move the button back to the menu panel. Then open the menu panel and choose to move it back to the toolbar.
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Comment on attachment 8372622 [details] [diff] [review]
always re-enable Australis character encoding button when it is removed from an area,

Review of attachment 8372622 [details] [diff] [review]:
-----------------------------------------------------------------

This should have a test :)
Attachment #8372622 - Flags: review?(jaws)
Attachment #8372622 - Attachment is obsolete: true
Comment on attachment 8372646 [details] [diff] [review]
always re-enable Australis character encoding button when it is removed from an area,

Review of attachment 8372646 [details] [diff] [review]:
-----------------------------------------------------------------

perfect, thanks!
Attachment #8372646 - Flags: review?(jaws) → review+
remote:   https://hg.mozilla.org/integration/fx-team/rev/b6cc210dcb55
Flags: in-testsuite+
Whiteboard: [Australis:P4] → [Australis:P4][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/b6cc210dcb55
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P4][fixed-in-fx-team] → [Australis:P4]
Target Milestone: --- → Firefox 30
Comment on attachment 8372646 [details] [diff] [review]
always re-enable Australis character encoding button when it is removed from an area,

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Australis
User impact if declined: Moving the character encoding widget to the toolbar in customize mode leaves it disabled in the toolbar
Testing completed (on m-c, etc.): locally, on m-c, has automated test
Risk to taking this patch (and alternatives if risky): none
String or IDL/UUID changes made by this patch: none
Attachment #8372646 - Flags: approval-mozilla-aurora?
Attachment #8372646 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.