when nesting Relative CSS positioning inside Absolute CSS positioning, links inside translated part don't work anymore

RESOLVED DUPLICATE of bug 13213

Status

()

Core
CSS Parsing and Computation
--
major
RESOLVED DUPLICATE of bug 13213
17 years ago
17 years ago

People

(Reporter: germain garand, Assigned: dbaron)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Tested with:
Mozilla 0.9.2
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010628

When you define an Absolute CSS positioning (let'say to the right), then 
inside this translation you define a Relative translation to the left,
every link that is moved outside the Absolutely Positioned part does not work 
(drawn as a link but not active)...

Simple example : http://www.phoenix-library.org/bug-moz-css.html

This behavior/bug contrast with Opera 5 and MSIE 5 and is quite ennoying 
because this structure is very often used in dynamic sites to "mimic" frames.

Comment 1

17 years ago
Yuk. I see this on Win2k 20010824

Should be OS: All/All

Comment 2

17 years ago
-> style system
Assignee: asa → dbaron
Component: Browser-General → Style System
QA Contact: doronr → ian
Duplicate of a very old bug.

*** This bug has been marked as a duplicate of 13213 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.