mac.com - Layout problem at Apple's iTools tour site

RESOLVED INVALID

Status

Tech Evangelism Graveyard
English US
P1
normal
RESOLVED INVALID
17 years ago
3 years ago

People

(Reporter: Chris Petersen, Assigned: Chris Nalls)

Tracking

({top100})

unspecified
top100

Details

(Whiteboard: [aok], URL)

(Reporter)

Description

17 years ago
Build: 2001082405
Platform: All
Expected Results: No missing aligned images or gaps between images.
What I got: Page is displayed with various gaps between images. Since the page
uses the following doctyp, standard mode is used:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
"http://www.w3.org/TR/html4/loose.dtd">

Steps to reproduce:

1) Go to any of these urls:

http://itools.mac.com/1/iTour/index.html

http://itools.mac.com/1/iTour/tour_email.html

http://itools.mac.com/1/iTour/tour_homepage.html

http://itools.mac.com/1/iTour/tour_idisk.html

2) Page is rendered with various gaps.

3) These pages rendered correctly when using either of the following DTD's :

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" >
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN"
"http://www.w3.org/TR/REC-html40/loose.dtd">
(Reporter)

Comment 1

17 years ago
Same problem with additional Apple pages:

http://www.apple.com/earthlink/dsl/jump2.html
http://www.apple.com/earthlink/dsl/more.html
Summary: Layout problem at Apples iTools tour site → Layout problem at Apple's iTools tour site
This looks like an evangelism issue.   bc?
Keywords: top100

Comment 3

17 years ago
petersen, can you develop a reduced test case?
Keywords: qawanted
(Reporter)

Comment 4

17 years ago
Sure, I will take a look at reducing to a test case. I just which we could
contact Apple to have them change the doctype to Transitional.

Comment 5

17 years ago
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
"http://www.w3.org/TR/html4/loose.dtd">

afaik the above dtd invokes standard mode layout. There has been much discussion
over this issue and the current consensus it to use this DTD to allow authors to
request standards mode layout with the transitional dtd.

The other dtds referenced in this bug invoke quirks mode layout which is
probably what Apple intends.

The general opinion is that this is an evangelism issue.

Comment 6

17 years ago
Ok, then -->bclary
Assignee: karnaze → bclary
Component: Layout → English: US
Product: Browser → Tech Evangelism
Version: other → unspecified

Comment 7

17 years ago
All/All, Major Site -> P1
Keywords: qawanted
Priority: -- → P1
Summary: Layout problem at Apple's iTools tour site → mac.com - Layout problem at Apple's iTools tour site

Comment 8

17 years ago
contact info http://itools.mac.com/1/iTour/index.html
Status: NEW → ASSIGNED
Target Milestone: --- → Dec

Updated

17 years ago
Blocks: 114156

Updated

17 years ago
Whiteboard: [aok]

Comment 9

17 years ago
-> chrisn
Assignee: bclary → chrisn
Status: ASSIGNED → NEW

Comment 10

16 years ago
This looks fixed to me, but I'm not absolutly sure. Can someone confirm. They
appear to have just removed their doctype declaration completly, which isn't
exactly the proper fix, but it whole doctype issue is getting weird.

Comment 11

16 years ago
status -> invalid. Pages don't exist anymore with iTools being replaced by .Mac. 
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.