table width does not update on reflow when image is wider than cells

VERIFIED WORKSFORME

Status

()

Core
Layout: Tables
P2
normal
VERIFIED WORKSFORME
17 years ago
15 years ago

People

(Reporter: pg, Assigned: karnaze (gone))

Tracking

({testcase})

Trunk
mozilla1.1alpha
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3+) Gecko/20010826
BuildID:    2001082606

The red box around the image overlapps the text

Reproducible: Always
Steps to Reproduce:
1.open the URL


Additional comments:
I tried to use composer to create a test case, but composer goes busy and does
not completely load the page.

Comment 1

17 years ago
confirmed, trying to get a testcase..
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: over lapping images → overlapping images
No, not browser problem at all.  They are using layers.  Website problem.  Over
to tech evangelism.
Assignee: karnaze → bclary
Severity: normal → major
Component: Layout → US English
OS: Linux → All
Priority: -- → P1
Product: Browser → Tech Evangelism
QA Contact: petersen → zach
Hardware: PC → All
Summary: overlapping images → nature.com - overlapping images
Whiteboard: [LAYER]
Version: other → unspecified

Comment 3

17 years ago
I'm sorry, this time there are no layers in the code :

<TABLE WIDTH="120" ALIGN="left" BGCOLOR="#0000CC"><TR BGCOLOR="#CC0000"><TD>
 <TABLE ALIGN="left"><TR><TD>
  <IMG SRC="http://www.mozilla.org/images/mozilla-banner.gif">
 </TD></TR></TABLE>
</TD></TR></TABLE>

Any layers here ? Don't think so. Testcase will be attached shortly, see for
yourself.
Severity: major → normal
Component: US English → Browser-General
Keywords: testcase
Priority: P1 → --
Product: Tech Evangelism → Browser
Summary: nature.com - overlapping images → <TR> wants to be bigger than <TABLE>
Whiteboard: [LAYER]
Version: unspecified → other

Comment 4

17 years ago
Created attachment 47174 [details]
Testcase for mentioned URL. Some description available inside, but no evanglism there =(

Comment 5

17 years ago
moving -> HTMLTables and undoing OS damage...
Assignee: bclary → karnaze
Component: Browser-General → HTMLTables
OS: All → Linux
QA Contact: zach → amar
Well, since I was on Windows at the time and I saw this problem, I will re-do
the so-called "OS damage" and put it back to OS->All.  Mac also has this problem
so there's no platform damage either.  The page does use layers and ilayers. 
It's written in the DOM and JavaScript.  Perhaps it's not what is causing this
though.  If your testcase is a simplified case of this bug, then you're right
it's not evangelism (and sorry to just jump on it like that). But this is
probably a dupe.

The problem here is that on initial load, the image sizes are not known so the
browser guesses and positions the two tables and text accordingly.  When the
images load, the images are wider than the browser guessed, so it loads the
image the correct size, but it doesn't reflow the table size accordingly and
thus the text is out of place.  Bug 63945 sounds like this.  Possibly related
also are Bug 52265 and bug 73069.  
Summary: <TR> wants to be bigger than <TABLE> → table width does not update on reflow when image is wider than cells
OS: Linux → All

Comment 7

17 years ago
The outer table's width is ok. That explains A) why the text is benath the
120px-line and B) the blue table background for the outer table.

And the image isn't wider than the cell - that's exactly the problem..

On the contrary - I neither have a good explanation nor a good Summary for this
effect.

Comment 8

16 years ago
WORKSFORME.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 9

16 years ago
Not fixed for me with N6.2.1 nor Mozilla 0.9.7.
re-opening.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 10

16 years ago
Oops, I thought this was an evangelism bug, this is why I have not tested it
with a nightly build and re-opened it. If reopened by mistake (and Nightly build
fixes the bug), please feel free to close again...
Priority: -- → P2

Updated

16 years ago
Target Milestone: --- → mozilla1.1

Comment 11

16 years ago
Build id 2002052508 on windows NT has this fixed.  I checked also with 1.0rc3
but the original url displays wrong there.  This has been anoying, and the site
valuable - thanks.

(Assignee)

Comment 12

16 years ago
wfm, and the image in the test case will not be 120px even though the table 
containing it has that width.
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WORKSFORME

Comment 13

16 years ago
verif
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.