bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

User should be able to reply via E-mail to their bugzilla E-mail notifications.

RESOLVED DUPLICATE of bug 44393

Status

()

Bugzilla
Email Notifications
--
enhancement
RESOLVED DUPLICATE of bug 44393
17 years ago
6 years ago

People

(Reporter: Pierre Chanial, Assigned: Jacob Steenhagen)

Tracking

Details

(Reporter)

Description

17 years ago
User should be able to reply via E-mail to their bugzilla E-mail notifications.

Why? 
- Huge saving of time.
- easier point per point argumented reply

Additional points:
- Bugzilla should be smart enough to remove the user signature if she/he omit to
remove it.
- it should be also smart enough to remove the quoted text, only if the quoted
text is reproduced as is.
(these two points could be worked around by adding a 'Reply by E-mail'
privilege)- Bugzilla should only accept messages coming from
CC'd+assigned+reporter to prevent against spamming
- E-mail notification for mid-air collision.

Comment 1

17 years ago
Implementation of this feature would be difficult for the following reasons :
Sending mails is easy: /usr/bin/sendmail or SMTP or LMTP or .. because :
  A) Bugzilla knows when to send mail
  B) it initiates the process

Receiving mails would be difficult : Receiving would only be possible with
POP3/IMAP4 or spooling into a file, but
  A) Bugzilla doesn't know when to receive mail
  B) Bugzilla is no process running all the time, it can't schedule operations
  B2) Bugzilla doesn't initiate the process
So there would be the need for a helper application using CRON or whatever.
To the additional points :
Since signatures always use "-- " (always ? hmm =)) this is not that difficult
to implement. Mid-air collision would be much more complicated since bugzilla
can only rely on the time you sent the mail. Any change since then would be a
collision, maybe even your own, last mail.

I think there is a much more sophisticated protocol for those issues : It's
called NNTP =)
Severity: major → enhancement
Bugzilla already has the capability to do this AFAIK.  It is however turned off
for bugzilla.mozilla.org

See the comments in bug 44393 for details.

*** This bug has been marked as a duplicate of 44393 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.