Move USE_STATIC_LIBS to moz.build

RESOLVED FIXED in mozilla30

Status

()

Core
Build Config
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Away for a while, Assigned: Away for a while)

Tracking

(Blocks: 1 bug)

Trunk
mozilla30
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
Created attachment 8373802 [details] [diff] [review]
Patch (v1)

The removals of this variable from the omx-plugin code are intentional, since that code is never built on Windows.
Attachment #8373802 - Flags: review?(mshal)
Attachment #8373802 - Flags: review?(mh+mozilla)
Attachment #8373802 - Flags: review?(gps)
Comment on attachment 8373802 [details] [diff] [review]
Patch (v1)

Review of attachment 8373802 [details] [diff] [review]:
-----------------------------------------------------------------

::: python/mozbuild/mozbuild/frontend/sandbox_symbols.py
@@ +231,5 @@
>          """Whether the library in this directory is a static library.
>          """, None),
>  
> +    'USE_STATIC_LIBS': (bool, bool,
> +        """Whether the code in this directory is a built against a static

should be built against the
Attachment #8373802 - Flags: review?(mshal)
Attachment #8373802 - Flags: review?(mh+mozilla)
Attachment #8373802 - Flags: review?(gps)
Attachment #8373802 - Flags: review+
(Assignee)

Comment 2

4 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/3e252a679f72
https://hg.mozilla.org/mozilla-central/rev/3e252a679f72
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla30

Updated

4 years ago
Duplicate of this bug: 964453
You need to log in before you can comment on or make changes to this bug.