Closed Bug 970757 Opened 6 years ago Closed 6 years ago

--with-system-icu broken

Categories

(Firefox Build System :: General, defect)

x86_64
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla30

People

(Reporter: Benjamin, Assigned: glandium)

References

Details

Attachments

(1 file)

I suspect this is a regression from bug 969164, since the build worked fine yesterday.

Linking libxul now spews the following:
/home/benjamin/dev/mozilla/inbound/js/src/builtin/Intl.cpp:738: error: undefined reference to 'ucol_getAvailable'
/home/benjamin/dev/mozilla/inbound/js/src/builtin/Intl.cpp:738: error: undefined reference to 'ucol_countAvailable'
/home/benjamin/dev/mozilla/inbound/js/src/builtin/Intl.cpp:755: error: undefined reference to 'ucol_getKeywordValuesForLocale'
/home/benjamin/dev/mozilla/inbound/js/src/builtin/Intl.cpp:762: error: undefined reference to 'uenum_count'
/home/benjamin/dev/mozilla/inbound/js/src/builtin/Intl.cpp:524: error: undefined reference to 'uenum_close'
/home/benjamin/dev/mozilla/inbound/js/src/builtin/Intl.cpp:774: error: undefined reference to 'uenum_next'
/home/benjamin/dev/mozilla/inbound/js/src/builtin/Intl.cpp:1226: error: undefined reference to 'unum_getAvailable'
/home/benjamin/dev/mozilla/inbound/js/src/builtin/Intl.cpp:1226: error: undefined reference to 'unum_countAvailable'
/home/benjamin/dev/mozilla/inbound/js/src/builtin/Intl.cpp:1683: error: undefined reference to 'udat_getAvailable'
/home/benjamin/dev/mozilla/inbound/js/src/builtin/Intl.cpp:1683: error: undefined reference to 'udat_countAvailable'
/home/benjamin/dev/mozilla/inbound/js/src/builtin/Intl.cpp:1721: error: undefined reference to 'ucal_open'
/home/benjamin/dev/mozilla/inbound/js/src/builtin/Intl.cpp:1722: error: undefined reference to 'ucal_getType'
/home/benjamin/dev/mozilla/inbound/js/src/builtin/Intl.cpp:1727: error: undefined reference to 'ucal_close'
/home/benjamin/dev/mozilla/inbound/js/src/builtin/Intl.cpp:1736: error: undefined reference to 'ucal_getKeywordValuesForLocale'
/home/benjamin/dev/mozilla/inbound/js/src/builtin/Intl.cpp:1743: error: undefined reference to 'uenum_count'
/home/benjamin/dev/mozilla/inbound/js/src/builtin/Intl.cpp:1750: error: undefined reference to 'uenum_next'
/home/benjamin/dev/mozilla/inbound/js/src/builtin/Intl.cpp:524: error: undefined reference to 'uenum_close'
/home/benjamin/dev/mozilla/inbound/js/src/builtin/Intl.cpp:1784: error: undefined reference to 'u_strlen'
/home/benjamin/dev/mozilla/inbound/js/src/builtin/Intl.cpp:1787: error: undefined reference to 'udatpg_open'
/home/benjamin/dev/mozilla/inbound/js/src/builtin/Intl.cpp:1795: error: undefined reference to 'udatpg_getBestPattern'
/home/benjamin/dev/mozilla/inbound/js/src/builtin/Intl.cpp:524: error: undefined reference to 'udatpg_close'
/home/benjamin/dev/mozilla/inbound/js/src/builtin/Intl.cpp:1806: error: undefined reference to 'udatpg_getBestPattern'
/home/benjamin/dev/mozilla/inbound/js/src/builtin/Intl.cpp:924: error: undefined reference to 'ucol_open'
/home/benjamin/dev/mozilla/inbound/js/src/builtin/Intl.cpp:930: error: undefined reference to 'ucol_setAttribute'
/home/benjamin/dev/mozilla/inbound/js/src/builtin/Intl.cpp:931: error: undefined reference to 'ucol_setAttribute'
/home/benjamin/dev/mozilla/inbound/js/src/builtin/Intl.cpp:932: error: undefined reference to 'ucol_setAttribute'
/home/benjamin/dev/mozilla/inbound/js/src/builtin/Intl.cpp:933: error: undefined reference to 'ucol_setAttribute'
/home/benjamin/dev/mozilla/inbound/js/src/builtin/Intl.cpp:937: error: undefined reference to 'ucol_close'
/home/benjamin/dev/mozilla/inbound/js/src/builtin/Intl.cpp:967: error: undefined reference to 'ucol_strcoll'
/home/benjamin/dev/mozilla/inbound/js/src/builtin/Intl.cpp:1020: error: undefined reference to 'ucol_close'
/home/benjamin/dev/mozilla/inbound/js/src/builtin/Intl.cpp:1863: error: undefined reference to 'u_strlen'
/home/benjamin/dev/mozilla/inbound/js/src/builtin/Intl.cpp:1871: error: undefined reference to 'u_strlen'
/home/benjamin/dev/mozilla/inbound/js/src/builtin/Intl.cpp:1879: error: undefined reference to 'udat_open'
/home/benjamin/dev/mozilla/inbound/js/src/builtin/Intl.cpp:1887: error: undefined reference to 'udat_getCalendar'
/home/benjamin/dev/mozilla/inbound/js/src/builtin/Intl.cpp:1888: error: undefined reference to 'ucal_setGregorianChange'
/home/benjamin/dev/mozilla/inbound/js/src/builtin/Intl.cpp:1907: error: undefined reference to 'udat_format'
/home/benjamin/dev/mozilla/inbound/js/src/builtin/Intl.cpp:1967: error: undefined reference to 'udat_close'
/home/benjamin/dev/mozilla/inbound/js/src/builtin/Intl.cpp:1912: error: undefined reference to 'udat_format'
/home/benjamin/dev/mozilla/inbound/js/src/builtin/Intl.cpp:1376: error: undefined reference to 'unum_open'
/home/benjamin/dev/mozilla/inbound/js/src/builtin/Intl.cpp:1384: error: undefined reference to 'unum_setTextAttribute'
/home/benjamin/dev/mozilla/inbound/js/src/builtin/Intl.cpp:1391: error: undefined reference to 'unum_setAttribute'
/home/benjamin/dev/mozilla/inbound/js/src/builtin/Intl.cpp:1392: error: undefined reference to 'unum_setAttribute'
/home/benjamin/dev/mozilla/inbound/js/src/builtin/Intl.cpp:1393: error: undefined reference to 'unum_setAttribute'
/home/benjamin/dev/mozilla/inbound/js/src/builtin/Intl.cpp:1417: error: undefined reference to 'unum_formatDouble'
/home/benjamin/dev/mozilla/inbound/js/src/builtin/Intl.cpp:1423: error: undefined reference to 'unum_formatDouble'
/home/benjamin/dev/mozilla/inbound/js/src/builtin/Intl.cpp:1245: error: undefined reference to 'icu::Locale::Locale(char const*, char const*, char const*, char const*)'
/home/benjamin/dev/mozilla/inbound/js/src/builtin/Intl.cpp:1247: error: undefined reference to 'icu::NumberingSystem::createInstance(icu::Locale const&, UErrorCode&)'
/home/benjamin/dev/mozilla/inbound/js/src/builtin/Intl.cpp:1258: error: undefined reference to 'icu::Locale::~Locale()'
/home/benjamin/dev/mozilla/inbound/js/src/builtin/Intl.cpp:1252: error: undefined reference to 'icu::NumberingSystem::getName()'
/home/benjamin/dev/mozilla/inbound/js/src/builtin/Intl.cpp:663: error: undefined reference to 'ucol_close'
/home/benjamin/dev/mozilla/inbound/js/src/builtin/Intl.cpp:1608: error: undefined reference to 'udat_close'
/home/benjamin/dev/mozilla/inbound/js/src/jsapi.cpp:589: error: undefined reference to 'u_init'
/home/benjamin/dev/mozilla/inbound/js/src/jsapi.cpp:620: error: undefined reference to 'u_cleanup'
/home/benjamin/dev/mozilla/inbound/js/src/jsapi.cpp:669: error: undefined reference to 'u_setMemoryFunctions'
collect2: error: ld returned 1 exit status
Attachment #8373838 - Flags: review?(gps)
Assignee: nobody → mh+mozilla
Status: NEW → ASSIGNED
Duplicate of this bug: 971669
Attachment #8373838 - Flags: review?(gps) → review+
https://hg.mozilla.org/mozilla-central/rev/69e8b2fa8b4c
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla30
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.