Closed Bug 970769 Opened 6 years ago Closed 6 years ago

MenuBar flickers when I click History/Tools menu in the first time

Categories

(Firefox :: Sync, defect, P2)

29 Branch
defect

Tracking

()

VERIFIED FIXED
Firefox 30
Tracking Status
firefox28 --- unaffected
firefox29 + verified
firefox30 + verified

People

(Reporter: alice0775, Assigned: ttaubert)

References

Details

(Keywords: regression)

Attachments

(1 file)

Build Identifier:
https://hg.mozilla.org/mozilla-central/rev/ecf20a2484b6
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0 ID:20140210030201
https://hg.mozilla.org/projects/holly/rev/5fa2eabfda49
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0 ID:20140206040204

MenuBar flickers and Browser jump.

This problem only happens in the first click.
This problem happens on Nightly30.0a1, Aurora29.0a2 as well as Holly29.0a2.

Steps To Reproduce:
1. Start Firefox with newly created clean profile
2. Press ALT key to show MenuBar
3. Click History or Tools

Actual Results:
MenuBar flickers

Expected Results:
Should not flicker

Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/7e79536aca0a
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0 ID:20140128132521
Bad:
http://hg.mozilla.org/mozilla-central/rev/044aec58f5b3
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0 ID:20140129023340
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=7e79536aca0a&tochange=044aec58f5b3


Regression window(fx)
Good:
http://hg.mozilla.org/integration/fx-team/rev/9fdb8b893c75
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0 ID:20140128173029
Bad:
http://hg.mozilla.org/integration/fx-team/rev/974df2f038ae
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0 ID:20140128175610
Pushlog:
http://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=9fdb8b893c75&tochange=974df2f038ae

In local build
Last Good: 5c74030c7c0e
First Bad: 974df2f038ae

Regressed by:
974df2f038ae	Mark Hammond — Bug 959222 (part 1) - Make browserid_identity a first-class identity module. r=rnewman
Component: Menus → Sync
Mark: this'll be computing whether to show Tabs From Other Devices and Set Up Sync.
Also seen on Ubuntu.
OS: Windows 7 → All
Best I can currently guess is that showing the tools menu causes sync to initialize its identity manager, and this is now a "spinning" operation.  But that doesn't explain why it's not obvious once a user is signed in - so I'll need to dig a little more into this.
Blocks: 905997
Assignee: nobody → ttaubert
Priority: -- → P2
Status: NEW → ASSIGNED
Hardware: x86_64 → All
Comment on attachment 8390091 [details] [diff] [review]
0001-Bug-970769-MenuBar-flickers-when-I-click-History-Too.patch

Review of attachment 8390091 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/base/content/browser-menubar.inc
@@ +443,5 @@
>                    label="&toolsMenu.label;"
>                    accesskey="&toolsMenu.accesskey;">
>                <menupopup id="menu_ToolsPopup"
>  #ifdef MOZ_SERVICES_SYNC
> +                         onpopupshowing="setTimeout(() => gSyncUI.updateUI());"

I think a comment saying why we do this would be good, so we know it's safe to undo this hack when we fix identity initialization such that we don't spin an event loop.
Attachment #8390091 - Flags: review?(mhammond) → review+
Comment on attachment 8390091 [details] [diff] [review]
0001-Bug-970769-MenuBar-flickers-when-I-click-History-Too.patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 959222
User impact if declined: Flickering menu bar when opening the Tools menu.
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): Low risk.
String or IDL/UUID changes made by this patch: None.
Attachment #8390091 - Flags: approval-mozilla-aurora?
Attachment #8390091 - Flags: approval-mozilla-aurora?
Comment on attachment 8390091 [details] [diff] [review]
0001-Bug-970769-MenuBar-flickers-when-I-click-History-Too.patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 959222
User impact if declined: Flickering menu bar when opening the Tools menu.
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): Low risk.
String or IDL/UUID changes made by this patch: None.
Attachment #8390091 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/d7ca6dbf3def
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 30
Attachment #8390091 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Keywords: verifyme
If by "flicker" you refer to the fact that the menu bar disappears for a fraction of a second after clicking History or Tools, then this is still reproducible on both Firefox 29 (Build ID: 20140421221237) and Aurora 30 2014-04-24 (Build ID: 20140424004002), on first click, with a clean profile, using:
 * Windows 7 64-bit [1],
 * Windows 8 Pro 64-bit [2],
 * Windows 8.1 Pro 64-bit (Microsoft Surface Pro 2) [3].

Please confirm.


1. Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0
2. Mozilla/5.0 (Windows NT 6.2; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0
3. Mozilla/5.0 (Windows NT 6.3; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0
Flags: needinfo?(ttaubert)
I can't reproduce this when clicking "Tools" but do indeed still see it when clicking "History". Seems like the history menu has the same problem but not caused by FxA. This regression or bug may have been around longer? Anyway, we should file a separate bug for that.

Andrei, can you please confirm that this has been fixed for the "Tools" menu?
Flags: needinfo?(ttaubert) → needinfo?(andrei.vaida)
(In reply to Tim Taubert [:ttaubert] from comment #14)
> I can't reproduce this when clicking "Tools" but do indeed still see it when
> clicking "History". Seems like the history menu has the same problem but not
> caused by FxA. This regression or bug may have been around longer? Anyway,
> we should file a separate bug for that.
> 
> Andrei, can you please confirm that this has been fixed for the "Tools" menu?
Thanks for the quick reply, Tim. 

This issue is no longer reproducible for the "Tools" menu, using Firefox 29 and Aurora 30 2014-04-25 (Build ID: 20140425004002) with the platforms mentioned in Comment 13. I will file a new bug for the History menu as soon as possible. Marking this one verified fixed.
Status: RESOLVED → VERIFIED
Flags: needinfo?(andrei.vaida)
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.