sesamestreet.org says "can't find what you're looking for" on video page

RESOLVED WORKSFORME

Status

Tech Evangelism
Mobile
RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: hallvors, Unassigned, Mentored)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [mobile-compat-form][lib-ump][video][contactready], URL)

(Reporter)

Description

4 years ago
Site: http://www.sesamestreet.org/videos
sesamestreet.org says "can't find what you're looking for" on video page

:: Steps To Reproduce

Load page - instead of a list of videos, there's an image of a green monster saying "Sorry, we can't find what you're looking for".

Note: this is a desktop site, not mobile. It does however list and play videos in Android browser.

Note 2: In Firefox for Android, the list of videos appear, but the thumbnails seem missing. The videos do play though.

:: Expected Result

Video

:: Actual Result

Error message

:: Additional Information

Software Version: 1.1
Reporter's User Agent: Mozilla/5.0 (Android; Mobile; rv:26.0) Gecko/26.0 Firefox/26.0
(Reporter)

Comment 1

4 years ago
One can provoke the same error message in desktop by disabling Flash.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [mobile-compat-form] → [mobile-compat-form][lib-ump][video]
(Reporter)

Comment 2

4 years ago
description
The underlying issue is that the site sends a JSON string of "capabilities" to the server when requesting a list of videos, and it seems the server isn't configured to return MP4 videos under some conditions, even if hasVideoSupport is true? (Perhaps it also requires isAndroid or isIOS to be true?)

String from Android device:
capabilities={"isIE":false,"isFirefox":true,"isChrome":false,"isWebKit":false,"isMobile":false,"isTablet":false,"isHandset":false,"isIOS":false,"isIOSHandset":false,"isIOSTablet":false,"isAndroid":true,"isAndroidTablet":false,"isAndroidHandset":true,"isKindle":false,"hasCanvasSupport":true,"hasTouchSupport":false,"hasFlashSupport":true,"hasVideoSupport":true}

String from Firefox OS:
capabilities={"isIE":false,"isFirefox":true,"isChrome":false,"isWebKit":false,"isMobile":false,"isTablet":false,"isHandset":false,"isIOS":false,"isIOSHandset":false,"isIOSTablet":false,"isAndroid":false,"isAndroidTablet":false,"isAndroidHandset":false,"isKindle":false,"hasCanvasSupport":true,"hasTouchSupport":true,"hasFlashSupport":auto,"hasVideoSupport":auto}
(Reporter)

Comment 3

4 years ago
suggestedfix
Now, it would be nice to get this fixed somewhere for desktop users with MP4-capable HTML5 browsers and Flash disabled. However, the best fix for Firefox OS is to add an automatic redirect to m.sesamestreet.org/videos - there is actually a mobile site, it just isn't advertised or redirected to.
(Reporter)

Updated

4 years ago
Whiteboard: [mobile-compat-form][lib-ump][video] → [mobile-compat-form][lib-ump][video][contactready]
Whiteboard: [mobile-compat-form][lib-ump][video][contactready] → [mobile-compat-form][lib-ump][video][contactready][mentor=astevenson]

Updated

4 years ago
Mentor: astevenson
Whiteboard: [mobile-compat-form][lib-ump][video][contactready][mentor=astevenson] → [mobile-compat-form][lib-ump][video][contactready]

Comment 4

3 years ago
This seems to be fixed.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.