cannot save draft *while* sending

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
18 years ago
11 years ago

People

(Reporter: siffert, Unassigned)

Tracking

({dataloss})

Trunk
x86
Linux
dataloss

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Sort of a weird combination of events here - I wrote a long email, and tried to
send it.  The From: address was set to my personal domain, which happened to be
unreachable at the time because my dns provider was down.  Anyway, I tried
sending it once and it chugged for a while and then gave me an error saying
"Could not verify address" or something - no problem.  Before I had figured out
why, I tried sending it again.  While it was chugging away, I clicked "Save",
which seemed to work okay, and then I clicked the upper-right "x" to make the
message (in the process of being sent) disappear from view.  Then I got the
"could not verify" error back again... and my email was nowhere to be found. 
Not in "Sent", not in "Drafts", nowhere on disk, nowhere.  I think the behaviour
should be that when "Save" is clicked it should Save in drafts, even if it is
attempting to send at the same time.

Thanks,
Curt

Updated

18 years ago
QA Contact: sheelar → esther
Sounds reasonable.  Marking NEW.  Adding dataloss keyword since the reporter
demonstrated how written emails can be lost.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: dataloss
Save button should be disable during a send operation...
->varada
Assignee: ducarroz → varada
taking all of varada's bugs.
Assignee: varada → sspitzer

Comment 4

16 years ago
By the definitions on <http://bugzilla.mozilla.org/bug_status.html#severity> and
<http://bugzilla.mozilla.org/enter_bug.cgi?format=guided>, crashing and dataloss
bugs are of critical or possibly higher severity.  Only changing open bugs to
minimize unnecessary spam.  Keywords to trigger this would be crash, topcrash,
topcrash+, zt4newcrash, dataloss.
Severity: normal → critical
Product: MailNews → Core
sorry for the spam.  making bugzilla reflect reality as I'm not working on these bugs.  filter on FOOBARCHEESE to remove these in bulk.
Assignee: sspitzer → nobody
I believe this is available.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

11 years ago
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.