Closed Bug 971059 Opened 6 years ago Closed 6 years ago

Signed in on Android and Desktop, and nothing is syncing.

Categories

(Firefox for Android :: Android Sync, defect)

Firefox 30
All
Android
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 967580
Tracking Status
firefox29 --- affected
firefox30 --- affected

People

(Reporter: ibarlow, Unassigned)

Details

Attachments

(1 file, 1 obsolete file)

Basically what the title says. I created and verified an account on my Mac, then logged into Nightly on Android, everything seemed to go successfully. 

But now, ten minutes later, nothing is syncing. 

If it helps, on Android I do *not* see the Sync Status page in settings with the options to turn checkboxes on and off. Rather I am seeing the "Account Verified, your data will begin syncing momentarily" screen. So maybe something is stuck?
Can you get an ADB log?
OS: Mac OS X → Android
Hardware: x86 → All
Mac Nightly 30.0a1 (2014-02-09)
Android Nightly 30.0a1 (2014-02-11)

Will post an adb log shortly
Attached file adb log (obsolete) —
Here you go Richard, let me know if there is anything useful in here
Comment on attachment 8375539 [details]
adb log

Hmm, I'm not seeing anything FxAccount or FxSync related at all.  Could be a log tag level needs to be set, but we'd see errors at least.  Did you run a Sync during this time, ibarlow?
I'm seeing the same issue here. I created and verified a FX account using Nightly for linux. After linking it to nightly for android, all indications were that it should sync.

If I go into the accounts and sync settings of android and manually start a sync for nightly, it looks to be working, and after a few seconds shows an updated time for when in last updated, but I see no change in the app itself.
(In reply to Chris DeCairos (:cade) from comment #5)
> I'm seeing the same issue here. I created and verified a FX account using
> Nightly for linux. After linking it to nightly for android, all indications
> were that it should sync.
> 
> If I go into the accounts and sync settings of android and manually start a
> sync for nightly, it looks to be working, and after a few seconds shows an
> updated time for when in last updated, but I see no change in the app itself.

Likewise, can you attach a logcat from when you attempt to Sync.
Attached file Another adb log
Here's another one Nick. I initiated a Sync here, so maybe it will tell you more than the last one did
Attachment #8375539 - Attachment is obsolete: true
Comment on attachment 8375668 [details]
Another adb log

Huh, token server credential error.  Clock skew?  Will look further.
Token failing every time seems… weird.
"invalid Hawk signature" could well be our old friend clock-skew striking again.  Definitely need a distinct error code here.
Just a heads up that I blew away my Nightly on Android and started over, and ran into the same problem again.
Thanks for being patient with this, Ian.
Ian, can you please check whether the clock on your android device is correct?  We hypothesized clock-skew as a cause above, it would be good to rule it in or out before digging further on this.
Flags: needinfo?(ibarlow)
It looks to be one minute offset from my laptop. Would that be enough to break it?

If so, we should probably make the clock-skew tolerance a little more forgiving...
Flags: needinfo?(ibarlow)
I think one minute is enough for 'correct' clocks.

I don't think a larger fudge factor is enough to solve this problem for incorrect clocks: 

http://opensignal.com/reports/timestamps/

-- 3.5% of Android device clocks are wrong by more than an hour.

We need to either switch to a different protocol that isn't so dependent on clock alignment, or continue to pile up sandbags of clock skew correction.
The default timestamp window we allow on the storage servers is 60 seconds, so this could well be enough to cause at least intermittent failures.

> We need to either switch to a different protocol that isn't so dependent on clock alignment,
> or continue to pile up sandbags of clock skew correction.

Yeah, I even had to correct for clockskew in the syncstorage loadtests: https://github.com/mozilla-services/server-syncstorage/blob/master/loadtest/stress.py#L110

:rnewman please raise your concerns/proposal here on sync-dev.  I feel like we're fairly committed to Hawk at this point, but at least for the storage servers, we may be able to find a better set of tradeoffs than the current scheme.
So just as an experiment I adjusted the clock on my phone by one minute and pressed "sync" and boom, my Aandroid Nightly started filling up with deskop bookmarks right away.
Component: FxA → General
Component: General → Android Sync
Product: Firefox for Android → Android Background Services
Ian mentioned in person that once he adjusted the time on his device Sync started working right away.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: clockskew
Product: Android Background Services → Firefox for Android
You need to log in before you can comment on or make changes to this bug.