Closed Bug 971123 Opened 6 years ago Closed 3 years ago

Update dialog is not displayed after nag interval

Categories

(Toolkit :: Application Update, defect)

26 Branch
All
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 893505

People

(Reporter: rnewman, Unassigned, NeedInfo)

References

Details

I just took a look at my girlfriend's Firefox install and found that it was still waiting to restart to install an update.

That update was Firefox 26. Release is currently 27.

I only found this because I clicked Firefox > About Firefox to check for updates, and found one pending.

I then had to do the same again to install 27.


It seems that if you miss the three-second system notification that a new update is available, you'll only restart Firefox if it crashes or you need to reboot the device.

This is not the first time this has happened — I previously found that she was unknowingly using Firefox 16 when Firefox 24 was out.


For my part, I often find that my Nightly is a week out of date, simply because I missed the prompt saying that a new version was ready to install.

This makes me wonder how many of our multiple-releases-behind users simply haven't restarted to install an update yet. Every few months they have to restart to install some OS update, and jump ahead by one Firefox version, gradually drifting far away from the current release.


Are there already bugs on file to do something like the following?

1. Nag at infrequent intervals, ideally with a persistent doorhanger rather than a system notification. This update was pending for something like 8 weeks; I don't see the harm in saying “You have an update waiting to be installed; click here to restart” every week.

2. Check for new pending updates even if one has been downloaded, such that the eventual reboot gets the user all the way to the new version, rather than just hopping forward by one.
There is an update dialog that is suppose to be displayed every 24 hours after a background download.

Regarding "Are there already bugs on file to do something like the following?"
1. it should already display a dialog. There is also a bug to use simpler ui that needs ux input.

2. yes.
Summary: Messaging around available updates is inadequate → Update dialog is not displayed after nag interval
(In reply to Robert Strong [:rstrong] (use needinfo to contact me) from comment #1)
> There is an update dialog that is suppose to be displayed every 24 hours
> after a background download.

How long does it stick around? What makes it go away?

I've never seen this for Nightly, and I don't recall ever seeing it on my girlfriend's release install. (And apparently she *always* has a pending background update!)
(In reply to Richard Newman [:rnewman] from comment #2)
> (In reply to Robert Strong [:rstrong] (use needinfo to contact me) from
> comment #1)
> > There is an update dialog that is suppose to be displayed every 24 hours
> > after a background download.
> 
> How long does it stick around? What makes it go away?
It is a dialog and must be user dismissed. It will re-display after each nag interval. iirc if the download is user initiated it isn't displayed which might be the cause (e.g. perhaps after displaying the about dialog it won't nag or some other such bug). Also, there are tests for this which likely doesn't cover this case.
Note: it may also have to do with staging where we have had a bug with notification.
Can this still be reproduced?
Flags: needinfo?(rnewman)
I'll take a look when I'm home from MozLondon.
Her machine is running 46.0.1.

An update was ready to download; IIRC opening About Firefox caused it to download. I closed the About Firefox window and left the app running several days ago. It's seen regular sleep/wake and use since then.

There have been no notifications of any kind, timed or otherwise -- the only way we can tell that there's a pending update is by opening About Firefox and seeing the "Restart to install updates" button.
Flags: needinfo?(rnewman)
(In reply to Richard Newman [:rnewman] from comment #7)
> Her machine is running 46.0.1.
> 
> An update was ready to download; IIRC opening About Firefox caused it to
> download. I closed the About Firefox window and left the app running several
> days ago. It's seen regular sleep/wake and use since then.
> 
> There have been no notifications of any kind, timed or otherwise -- the only
> way we can tell that there's a pending update is by opening About Firefox
> and seeing the "Restart to install updates" button.

(In reply to Robert Strong [:rstrong] (use needinfo to contact me) from comment #1)
> There is an update dialog that is suppose to be displayed every 24 hours
> after a background download.
This wasn't a background download so the notification won't be displayed since the download was user initiated.

Is the system set to automatically update (e.g. tools -> options -> advanced -> update)?
Could the dialog been dismissed without seeing it?

Note: we are working on changing the notification ui which should alleviate this.
(In reply to Robert Strong [:rstrong] (use needinfo to contact me) from comment #8)
> (In reply to Richard Newman [:rnewman] from comment #7)
> > Her machine is running 46.0.1.
> > 
> > An update was ready to download; IIRC opening About Firefox caused it to
> > download. I closed the About Firefox window and left the app running several
> > days ago. It's seen regular sleep/wake and use since then.
> > 
> > There have been no notifications of any kind, timed or otherwise -- the only
> > way we can tell that there's a pending update is by opening About Firefox
> > and seeing the "Restart to install updates" button.
> 
> (In reply to Robert Strong [:rstrong] (use needinfo to contact me) from
> comment #1)
> > There is an update dialog that is suppose to be displayed every 24 hours
> > after a background download.
> This wasn't a background download so the notification won't be displayed
> since the download was user initiated.
> 
> Is the system set to automatically update (e.g. tools -> options -> advanced
> -> update)?
> Could the dialog been dismissed without seeing it?
meant to say without knowing what it was for
(In reply to Robert Strong [:rstrong] (use needinfo to contact me) from comment #8)

> This wasn't a background download so the notification won't be displayed
> since the download was user initiated.

Got it. I'll see if this recurs with 46.0.2 or 47, and I'll wait for a background download, see if a notification occurs.

> Could the dialog been dismissed…?

I don't think so. This was an opt-in experiment on my wife's part :)
Flags: needinfo?(rnewman)
This should be fixed by the new doorhanger notification implemented in bug 893505.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 893505
You need to log in before you can comment on or make changes to this bug.