Closed Bug 971162 Opened 7 years ago Closed 7 years ago

[B2G][Clock][Alarm] Clock alarm has vibration when alarm vibration is set to off

Categories

(Firefox OS Graveyard :: Gaia::Clock, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:1.4+, b2g-v1.3 unaffected, b2g-v1.4 verified)

VERIFIED FIXED
1.4 S1 (14feb)
blocking-b2g 1.4+
Tracking Status
b2g-v1.3 --- unaffected
b2g-v1.4 --- verified

People

(Reporter: bzumwalt, Assigned: mcav)

Details

(Keywords: regression, smoketest, Whiteboard: [priority][p=1])

Attachments

(2 files)

Attached file Logcat
Description:
When user creates new alarm in Clock app, setting the vibration to "off" in that alarm's settings does not prevent phone from vibrating when alarm fires.

Repro Steps:
1) Updated Buri to BuildID: 20140211040200
2) Open Clock app
3) Tap new alarm icon in top right corner
4) Set alarm for future time with vibration set to "off"
5) Select "Done"
6) Wait for alarm to fire

Actual:
Alarm with vibration set to "off" still has vibration when alarm fires.

Expected:
Alarm with vibration set to "off" has no vibration when alarm fires.

Environmental Variables:
Device: Buri v1.4 Mozilla RIL
BuildID: 20140211040200
Gaia: 9fc36dde3a4a3c5ca200275b68ffb56b4173bec3
Gecko: d812f80a0f1d
Version: 30.0a1
Firmware Version: V1.2-device.cfg

Notes:
Repro frequency: 3/3, 100%
See attached: logcat
Fails very basic functionality... 

Works fine on 1.3 - doesn't vibrate when set to Off, vibrates when set to On
Buri v1.3
BuildID: 20140211004035
Gaia: 00cd1ae74dfe773a41b55275b0b468a62f35076d
Gecko: 873e98e750bf
Version: 28.0
Firmware Version: v1.2-devices.cfg
blocking-b2g: --- → 1.4?
QA Contact: mvaughan
This issue started reproducing on the 01/17/14 Master (1.4) build.

- Works -
Device: Buri v1.4 MOZ RIL
BuildID: 20140116040206
Gaia: 82878ba16172213cd00ba3e8b377564b290e59c1
Gecko: 324e2cba1029
Version: 29.0a1
Firmware Version: V1.2-device.cfg

- Broken -
Device: Buri v1.4 MOZ RIL
BuildID: 20140117041037
Gaia: ef8bb31b462f364b57432a0724c78034d3f4f303
Gecko: b53589696cf8
Version: 29.0a1
Firmware Version: V1.2-device.cfg
blocking-b2g: 1.4? → 1.4+
Whiteboard: [priority]
Assignee: nobody → m
Status: NEW → ASSIGNED
Attachment #8375107 - Flags: review?(gaye)
Whiteboard: [priority] → [priority][p=1]
Target Milestone: --- → 1.4 S1 (14feb)
Comment on attachment 8375107 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/16228

Nice job mcav :)
Attachment #8375107 - Flags: review?(gaye) → review+
Thanks Gareth! Landed in master:

https://github.com/mozilla-b2g/gaia/commit/3c54aedf659b4792e4a1eb1f3ede8b266138cef7
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Comment on attachment 8375107 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/16228

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined:
[Testing completed]:
[Risk to taking this patch] (and alternatives if risky):
[String changes made]:
Attachment #8375107 - Flags: approval-gaia-v1.3?(fabrice)
Fabrice, this one already landed this afternoon but flagging you to take a look and let us know if any further action is required.
Comment on attachment 8375107 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/16228

Clearing approval request -- this is for 1.4.
Attachment #8375107 - Flags: approval-gaia-v1.3?(fabrice)
Reopening to figure out why the tests are sad.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Can we please do a backout to start with to avoid the smoketest failures ?
Flags: needinfo?(m)
Sorry for being unclear; the patch was backed out as of yesterday, in line with Comment 9. I'm going to land a proper fix today.
Flags: needinfo?(m)
Relanded in master:

https://github.com/mozilla-b2g/gaia/commit/49e7bbda552eb7ce45ecd20d22ccdf7eaabe35af

Still awaiting results from TBPL; will reopen/back out if there are any further problems (none anticipated).
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → FIXED
Verified fixed.
Alarm with vibration set to "off" has no vibration when alarm fires.

Buri, master build:
BuildID: 20140219040204
Gaia: ac06cfbd2baf6494ffbb668cc599e3892cd5e17b
Gecko: bf0e76f2a7d4
Version: 30.0a1
v1.2-devices.cfg
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.