Preferences links to Terms of Service and Privacy Notice are too high and and too large

VERIFIED FIXED in Firefox 29

Status

()

Firefox
Sync
P2
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: rfeeley, Assigned: mak)

Tracking

unspecified
Firefox 30
Points:
---
Dependency tree / graph
Bug Flags:
firefox-backlog +

Firefox Tracking Flags

(firefox29 verified, firefox30 verified)

Details

(Whiteboard: p=2 s=it-30c-29a-28b.2 [qa!])

Attachments

(2 attachments, 3 obsolete attachments)

(Reporter)

Description

4 years ago
Much like my city’s mayor, the links to the Terms of Service and Privacy Notice in Preferences are too high and too large.

Current:
https://www.dropbox.com/s/sk1yayd3ldx55kc/terms-current.png

Proposed:
https://www.dropbox.com/s/o5ettzd2c94ftn3/terms-proposed.png

Please bump font size down, and align vertically with [?] icon.
Blocks: 969593, 950073
OS: Mac OS X → All
Hardware: x86 → All
Whiteboard: p=0
Ryan, can you please attach new mockups or fix the linked ones? Thanks!
Flags: needinfo?(rfeeley)
Ryan mentioned in another bug (he probably meant this one) that BugzillaJS is the cause and he is right, sorry. Opening those images in new tabs works as expected.
Flags: needinfo?(rfeeley)

Updated

4 years ago
Assignee: nobody → mak77
Status: NEW → ASSIGNED
Whiteboard: p=0 → p=2 s=it-30c-29a-28b.2

Updated

4 years ago
QA Contact: twalker
Whiteboard: p=2 s=it-30c-29a-28b.2 → p=2 s=it-30c-29a-28b.2 [qa+]
(Assignee)

Comment 3

4 years ago
Created attachment 8380025 [details]
Schermata 2014-02-22 alle 00.04.55.png

We can't easily align the links with the help icon, cause the help icon is actually a button part of the preferences dialog, it is part of the same area where you usually find Accept/Cancel buttons, and out of the prefpane containing sync prefs. It would require deeper changes or css hacks that may also be bogus on hi-dpi settings. in-content preferences won't have issues aligning, since there is no help icon at all there, and since those are the future target for prefs I don't think it's worth to spend time refactoring the preferences dialog to add links into the footer.
This is what we can do easily, would that be enough?
Attachment #8380025 - Flags: feedback?(rfeeley)
(Assignee)

Comment 4

4 years ago
Created attachment 8380026 [details] [diff] [review]
patch v1
(Assignee)

Comment 5

4 years ago
Created attachment 8380029 [details] [diff] [review]
patch v1

the right patch...
Attachment #8380026 - Attachment is obsolete: true
(Assignee)

Comment 6

4 years ago
Created attachment 8381421 [details] [diff] [review]
patch  v2

on top of the patch in bug 965032
Attachment #8380029 - Attachment is obsolete: true

Updated

4 years ago
Blocks: 976607
Priority: -- → P2
No longer blocks: 976607
(Assignee)

Comment 7

4 years ago
John, based on the mockup at https://bug976617.bugzilla.mozilla.org/attachment.cgi?id=8381490 we seem to be using the default font size for any links, should we use a smaller font size for the links specified here or keep everything at default font size?
Flags: needinfo?(jgruen)

Comment 8

4 years ago
Marco, let's make the link copy for Terms of Service/ Privacy Notice small. Otherwise links should be normal size.
Flags: needinfo?(jgruen)
(Assignee)

Updated

4 years ago
Attachment #8380025 - Flags: feedback?(rfeeley)
(Assignee)

Comment 9

4 years ago
Created attachment 8383282 [details] [diff] [review]
patch v3

let's go with it
Attachment #8381421 - Attachment is obsolete: true
Attachment #8383282 - Flags: review?(ttaubert)
Comment on attachment 8383282 [details] [diff] [review]
patch v3

Review of attachment 8383282 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks!
Attachment #8383282 - Flags: review?(ttaubert) → review+
(Assignee)

Comment 11

4 years ago
https://hg.mozilla.org/integration/fx-team/rev/2789e24048c9
Target Milestone: --- → Firefox 30
https://hg.mozilla.org/mozilla-central/rev/2789e24048c9
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 13

4 years ago
Comment on attachment 8383282 [details] [diff] [review]
patch v3

[Approval Request Comment]
Bug caused by (feature/regressing bug #): no regression
User impact if declined: Sync preferences UI looks bad
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): styling changes, low risk
String or IDL/UUID changes made by this patch: none
Attachment #8383282 - Flags: approval-mozilla-aurora?
status-firefox29: --- → affected
status-firefox30: --- → fixed
Attachment #8383282 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/e2d7499fa0b5

This needed [Australis] in the commit message to make the hg commit hook happy. Not sure if this needs backing out on Holly or not, though.
status-firefox29: affected → fixed

Updated

4 years ago
Status: RESOLVED → VERIFIED
status-firefox29: fixed → verified
status-firefox30: fixed → verified
Whiteboard: p=2 s=it-30c-29a-28b.2 [qa+] → p=2 s=it-30c-29a-28b.2 [qa!]

Updated

4 years ago
No longer blocks: 950073
Flags: firefox-backlog+
You need to log in before you can comment on or make changes to this bug.