hamachi: 'Unknown SIM card state' or 'No SIM' after flashed with self-build build

RESOLVED FIXED in Firefox OS v2.2

Status

Firefox OS
RIL
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Bob, Assigned: Johannes W)

Tracking

unspecified
2.1 S9 (21Nov)

Firefox Tracking Flags

(blocking-b2g:-, b2g-v2.2 fixed)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:27.0) Gecko/20100101 Firefox/27.0 (Beta/Release)
Build ID: 20140127194636

Steps to reproduce:

Alcatel one touch fire (qcom) / hamachi  (Congstar / Germany)
b2g v1.2 & v1.4 self-build builds

followed the 'Build & Install' guides:
https://developer.mozilla.org/en-US/docs/Mozilla/Firefox_OS/Firefox_OS_build_prerequisites
https://developer.mozilla.org/en-US/Firefox_OS/Preparing_for_your_first_B2G_build
https://developer.mozilla.org/en-US/Firefox_OS/Building
https://developer.mozilla.org/en-US/Firefox_OS/Installing_on_a_mobile_device

BRANCH=v1.2 ./config.sh hamachi
./build.sh clean
./build.sh
./flash.sh -f

for v1.4
./config.sh hamachi
./build.sh clean
./build.sh
./flash.sh -f


Actual results:

after flashing the Alcatel device the SIM card is not useable. I am unable to place or receive calls, and i am unable to to use cellular data, too.

v1.2: 'Unknown SIM card state' 
v1.4: 'No SIM'




Expected results:

The SIM card should work normally. It should be possible to place and receive calls and use celluar data, too.
(Reporter)

Comment 1

3 years ago
Created attachment 8374728 [details]
logcat.log

logcat of branch v1.2
(Assignee)

Comment 2

3 years ago
I can confirm this bug. I had the same problem with my Alcatel One Touch Fire, branch v1.2 and v1.4 (master).

I solved it by applying this fix by cargabsj175:
https://github.com/weisslj/b2g-manifest/commit/4ac56ab8743e250e29647c83a675b526d9c4c517

@Bob: Can you try to build with https://github.com/weisslj/B2G? It is equal to the current B2G master (1727144), but uses b2g-manifest with the above fix applied.

This is the dev-b2g thread that helped me:
https://groups.google.com/d/msg/mozilla.dev.b2g/D_mc4bY7MSg/fnih9d64QSkJ

Updated

3 years ago
blocking-b2g: --- → -
(Reporter)

Comment 3

3 years ago
@Johannes W: I try to build the branch v1.2 with https://github.com/weisslj/B2G but at the end i got the same result. the SIM card is not working.
(Assignee)

Comment 4

3 years ago
@Bob: It will only work if you do not limit the branch to v1.2. Try ./config.sh without BRANCH!

Comment 5

3 years ago
I have the same issue on my hamachi (Alcatel OneTouch Fire). Affected branches: v1.2, v1.4 and v2.1 (master). Proposed solution works (checkout branch "caf/b2g/ics_strawberry_v1" in "hardware/ril" ), so please merge it (because phone without functionality of phone is not usable)
(Assignee)

Comment 6

3 years ago
Created attachment 8496566 [details] [review]
Fix "No SIM card" on Alcatel One Touch Fire

Bob informed me that the solution in comment #2 works, and if I would like to create a pull request. I asked the original author of the patch, Carlos Sánchez, and he agreed:
https://github.com/mozilla-b2g/b2g-manifest/pull/222
Attachment #8496566 - Flags: review?(mwu)

Comment 7

3 years ago
Please try to rename or remove file /system/bin/rilproxy and restart the device.

Comment 8

3 years ago
Comment on attachment 8496566 [details] [review]
Fix "No SIM card" on Alcatel One Touch Fire

Thanks for the PR. I'd like you to check one thing first though - remove the rilproxy repo from the manifest, and make sure your build doesn't have rilproxy in /system/bin/. If that works, please submit a PR to remove rilproxy instead.
Attachment #8496566 - Flags: review?(mwu)

Comment 9

3 years ago
I can confirm that I manually remove rilproxy from /system/bin and it works (modem works).
(Assignee)

Comment 10

3 years ago
(In reply to mac from comment #7)
> Please try to rename or remove file /system/bin/rilproxy and restart the device.

(In reply to Michael Wu [:mwu] from comment #8)
> Thanks for the PR. I'd like you to check one thing first though - remove the rilproxy repo from the manifest, [...]

Thanks for the replies! I will try that, unfortunately I can only do it next week.

Comment 11

3 years ago
ZTE Open C, OS Version 2.1.0.0-prerelease, build identifier 20141008000201

My phone went into the "Unknown SIM card state" today.  The upper-right corner signal strength meter showed 5 bars and if I pulled down the "windowshade" it showed "T - Mobil".  The Settings sections "Call Settings", "Messaging Settings", and "Cellular & Data" all reported "Unknown SIM card state".  Couldn't place calls or send text messages.

I saw in a different bug that it might have something to do with airplane mode.  I double-checked that I was not in airplane mode but nonetheless I enabled airplane mode and then disabled it and now things are working again.
(Assignee)

Comment 12

3 years ago
Created attachment 8520237 [details] [review]
Fix "No SIM card" on Alcatel One Touch Fire by removing rilproxy binary

I finally got time to test the suggestion of removing `/system/bin/rilproxy`, and it works!

I created a new pull request in https://github.com/mozilla-b2g/b2g-manifest/pull/242
Attachment #8496566 - Attachment is obsolete: true
Attachment #8520237 - Flags: review?(mwu)

Updated

3 years ago
Attachment #8520237 - Flags: review?(mwu) → review+

Updated

3 years ago
Keywords: checkin-needed
Master: https://github.com/mozilla-b2g/b2g-manifest/commit/9076b79ac80f4a272e3ff3b8b0341a0eb1da55a1
Assignee: nobody → jargon
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
status-b2g-v2.2: --- → fixed
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 2.1 S9 (21Nov)
You need to log in before you can comment on or make changes to this bug.