Segfault crash when trying to open URL

VERIFIED DUPLICATE of bug 97970

Status

()

Core
Networking
--
critical
VERIFIED DUPLICATE of bug 97970
17 years ago
17 years ago

People

(Reporter: johann.petrak@gmail.com, Assigned: Bill Law)

Tracking

({crash, stackwanted})

Trunk
x86
Linux
crash, stackwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
using build 2001082706 (linux)

On the top of page http://slate.msn.com/Features/bushisms/bushisms.asp are links
to a video.
Clicking these will make the browser crash with a segmentation fault error.
The content of the link is (including headers): 

HTTP/1.0 200 OK
Server: Cougar 4.1.0.3920
Content-Type: video/x-ms-asf
Content-Length: 140

[Reference]
Ref1=http://CPIBSNSA03:80/slate/0417_Bushisms_Slate_110k.asf
Ref2=http://207.46.178.14:80/slate/0417_Bushisms_Slate_110k.asf

I use the talkback version but talkback did not get activated.
(Button 3 -> save link as ... works though)

Updated

17 years ago
Severity: normal → critical
Keywords: crash

Comment 1

17 years ago
WFM 2001082706 -- clicking the links prompts me to download the file.  Do you
have plugins installed?  (I don't.)

Comment 2

17 years ago
WFM 20010826 Linux

Updated

17 years ago
Keywords: stackwanted
(Reporter)

Comment 3

17 years ago
Works with SPARC/Solaris 2001081510.
The Linux 2001082706 crashes here also when I try to access a copy of the file
that I put up at my local http server. Accessing the same file via a file://  URL
results in the disply of
   "<html><body></body></html>"

I have no plugins installed (except the null plugin).


(Reporter)

Comment 4

17 years ago
Tried with build 2001082708/Linux: crash, but talkback got invoked: TB34616230Y

Comment 5

17 years ago
WFM linux 2001083108, but I have no plugins and a save dialog is shown. Seems
like a plugin issue, but what plugins do you people have? 
(Reporter)

Comment 6

17 years ago
As I said, I have no plugins installed. I got this on two completely different linux
installations, but on the second installation talkback doesnt get initialized.

I also got a crash when clicking on a link to a file with "tgz" or "gz" extension,
so i suspect this has to do with handling extensions.

Comment 7

17 years ago
Does it always happen or is it intermittent? Can you run mozilla through
gdb and send us a stack trace (a 'where') when it crashes?
CC Stephend for the Talkback (TB34616230Y)

Comment 10

17 years ago
crash in helper stuff. ->law
Assignee: asa → law
Status: UNCONFIRMED → NEW
Ever confirmed: true
dupe of bug 97970


*** This bug has been marked as a duplicate of 97970 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 12

17 years ago
VERFIED: same problem
-> Networking
Status: RESOLVED → VERIFIED
Component: Browser-General → Networking
You need to log in before you can comment on or make changes to this bug.