Closed Bug 971426 Opened 6 years ago Closed 6 years ago

Unable to compile js shells on Windows

Categories

(Core :: JavaScript Engine, defect, blocker)

x86
Windows 7
defect
Not set
blocker

Tracking

()

VERIFIED FIXED
mozilla30
Tracking Status
firefox28 --- unaffected
firefox29 --- fixed
firefox30 --- fixed

People

(Reporter: gkw, Assigned: glandium)

References

(Blocks 1 open bug)

Details

(Keywords: regression, Whiteboard: [fuzzblocker])

Attachments

(2 files, 1 obsolete file)

Attached file stack (obsolete) —
I'm unable to compile js shells on Windows - I think it used to work at the start of the year.

Steps:
1. In js/src, run autoconf-2.13
2. Create and cd into objdir
3. Run: MAKE=mozmake AR=ar sh ../configure --enable-optimize --enable-debug --enable-profiling --enable-gczeal --enable-debug-symbols --enable-methodjit --enable-type-inferenc
e --disable-tests --enable-more-deterministic --enable-exact-rooting --disable-threadsafe
4. Run: mozmake -j10 -s
Tested on mozilla-central 802d87c77e76 and on MozillaBuild 1.9.0 test build.
Please attach a log without -s.
Attached file j1BuildLog.txt
-j1 build log
Attachment #8374591 - Attachment is obsolete: true
Flags: needinfo?(mh+mozilla)
I was also using MSVC 2010.
Assignee: nobody → mh+mozilla
Status: NEW → ASSIGNED
Comment on attachment 8374670 [details] [diff] [review]
Define IMPL_MFBT when building standalone js

Gary, can you try this patch?
Attachment #8374670 - Flags: feedback?(gary)
Flags: needinfo?(mh+mozilla)
Comment on attachment 8374670 [details] [diff] [review]
Define IMPL_MFBT when building standalone js

feedback+ because this seems to be able to fix non-threadsafe 32-bit builds on Windows. \o/
Attachment #8374670 - Flags: feedback?(gary) → feedback+
Blocks: 958404
Comment on attachment 8374670 [details] [diff] [review]
Define IMPL_MFBT when building standalone js

js/src/moz.build, before bug 958404, included mfbt/common.mozbuild, which did define IMPL_MFBT.
Attachment #8374670 - Flags: review?(gps)
Note, if you want to avoid js standalone builds being broken by build system changes, you should get them running on automation. I can't guarantee that other upcoming changes are not going to break you again.
(And as this bug shows, the current coverage of these builds on linux is insufficient to catch all the problems)
(In reply to Mike Hommey [:glandium] from comment #9)
> Note, if you want to avoid js standalone builds being broken by build system
> changes, you should get them running on automation. I can't guarantee that
> other upcoming changes are not going to break you again.

I filed bug 972089. Apparently bug 785798 removed them in the past.
Attachment #8374670 - Flags: review?(gps) → review+
https://hg.mozilla.org/mozilla-central/rev/f76b7bc18dbc
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla30
I've verified that this works now for m-c, and should be backported to aurora too. (will need nomination for approval flag)
Status: RESOLVED → VERIFIED
Flags: needinfo?(mh+mozilla)
Flags: needinfo?(mh+mozilla)
Whiteboard: [fuzzblocker] → [fuzzblocker] [checkin-needed-aurora] [npotb]
https://hg.mozilla.org/releases/mozilla-aurora/rev/fe15cb97d779
Whiteboard: [fuzzblocker] [checkin-needed-aurora] [npotb] → [fuzzblocker]
(In reply to Gary Kwong [:gkw] [:nth10sd] from comment #0)
> Steps:
> ...
> 4. Run: mozmake -j10 -s

ehoogeveen pointed to me over IRC that this step may have needed the environment as well:

MAKE=mozmake mozmake -j10 -s
You need to log in before you can comment on or make changes to this bug.