Relative and absolute positioning does not work on display: table-cell

RESOLVED DUPLICATE of bug 63895

Status

()

Core
DOM: CSS Object Model
RESOLVED DUPLICATE of bug 63895
4 years ago
4 years ago

People

(Reporter: Ben Frain, Unassigned)

Tracking

30 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:30.0) Gecko/20100101 Firefox/30.0 (Beta/Release)
Build ID: 20140206030201

Steps to reproduce:

Create an element and assign relative positioning, then specify a pseudo selector of it with absolute positioning. The absolute positioning is not relative to the pseudo element's parent.

Here is a reduction: http://codepen.io/benfrain/pen/uAahf


Actual results:

Firefox renders the absolutely positioned pseudo element against a different reference point. 


Expected results:

Firefox should position the pseudo element in relation to it's nearest relatively positioned parent element (the table-cell with position: relative; set).

You can see the expected behavior by looking at the reduction in Chrome/Safari: http://codepen.io/benfrain/pen/uAahf
(Reporter)

Updated

4 years ago
Status: UNCONFIRMED → NEW
Component: Untriaged → DOM: CSS Object Model
Ever confirmed: true
Product: Firefox → Core
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 63895
You need to log in before you can comment on or make changes to this bug.