The top edge of containing box of <fieldset> with <legend> for absolute positioning is different from IE and Chrome

RESOLVED DUPLICATE of bug 942341

Status

()

Core
Layout: R & A Pos
RESOLVED DUPLICATE of bug 942341
4 years ago
4 years ago

People

(Reporter: masayuki, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 8374725 [details]
screenshot

This is similar to bug 942341, but I'm not sure this is really dup of it.

If <fieldset> element with <legend> element establishes containing box for absolute positioning, its top edge is bottom of <legend> on Gecko. However, on Chrome and IE, the top edge is same as the top edge of <legend>.

See the testcase:
http://jsfiddle.net/d_toybox/X2U8J/2/

And attached screenshot.
Although, I like the Gecko's behavior better. However, this difference makes web developers complain about us.

# <fieldset> with <legend> laid out like replaced element. So, I guess that there is no standard spec about this...
Blocks: 971655
Sure looks like a dup to me.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 942341
You need to log in before you can comment on or make changes to this bug.