Closed Bug 971660 Opened 6 years ago Closed 5 years ago

[tablet] - Settings menu options are not staying highlighted

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox27 --- affected
firefox28 --- affected
firefox29 --- affected
firefox30 --- affected

People

(Reporter: cos_flaviu, Unassigned, Mentored)

Details

(Keywords: polish, Whiteboard: [tablet])

Environment: 
Device: Lenovo Yoga Tab 10 (Android 4.2.2);
Build: Nightly 30.0a1 (2014-02-11).

Steps to reproduce:
1. Launch fennec;
2. Go to settings;
3. Tap on any menu option from the settings page.

Expected result:
The tapped menu option remains highlighted.

Actual result:
The tapped menu option does not remain highlighted.

Notes:
Not reproducible on Asus Transformer Tab (Android 4.0.3).
Please check the video: http://www.youtube.com/watch?v=--C-Vw_3H_w
I bet this fix can be mentored.
Keywords: polish
Summary: Settings menu options are not staying highlighted → [tablet] - Settings menu options are not staying highlighted
Whiteboard: [tablet]
(In reply to Aaron Train [:aaronmt] from comment #1)
> I bet this fix can be mentored.

liuche? :)
Flags: needinfo?(liuche)
I'd be happy to mentor this, though it might be a little tricky to debug if it's device-specific.

The first step might be trying to narrow down what is affected: tablets running 4.2, just the one device, possibly other tablets?

Flaviu, do other tablet-mode settings on this device show the highlighting problem? What about other 4.2 tablets (Firefox, as well as other settings)?
Flags: needinfo?(liuche) → needinfo?(flaviu.cos)
Whiteboard: [tablet] → [tablet][mentor=liuche]
Softvision team does not have any other 4.2 tablet.
The bug is also reproducible using Gmail app and Youtube app.
Looks like the bug is device specific.
Flags: needinfo?(flaviu.cos)
Mentor: liuche
Whiteboard: [tablet][mentor=liuche] → [tablet]
No longer reproducible after updating the tablet OS to Android 4.4.2. 
Closing the bug as worksforme.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.