Closed Bug 971735 Opened 6 years ago Closed 6 years ago

java.util.ConcurrentModificationException: at java.util.ArrayList$ArrayListIterator.next(ArrayList.java) in removeHistoricalRecordsForPackage()

Categories

(Firefox for Android :: General, defect)

All
Android
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 30
Tracking Status
firefox28 --- fixed
firefox29 --- fixed
firefox30 --- fixed
b2g-v1.3 --- fixed

People

(Reporter: lucasr, Assigned: lucasr)

References

Details

Crash Data

Attachments

(1 file)

83b34bca-ec7a-489e-9d02-b97222140211

java.util.ConcurrentModificationException
	at java.util.ArrayList$ArrayListIterator.next(ArrayList.java:569)
	at org.mozilla.gecko.widget.ActivityChooserModel.access$600(ActivityChooserModel.java:104)
	at org.mozilla.gecko.widget.ActivityChooserModel$DataModelPackageMonitor.onReceive(ActivityChooserModel.java:1218)
	at android.app.LoadedApk$ReceiverDispatcher$Args.run(LoadedApk.java:763)
	at android.os.Handler.handleCallback(Handler.java:725)
	at android.os.Handler.dispatchMessage(Handler.java:92)
	at android.os.Looper.loop(Looper.java:175)
	at android.app.ActivityThread.main(ActivityThread.java:5279)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:511)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:1102)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:869)
	at dalvik.system.NativeStart.main(Native Method)
Blocks: 881861
Comment on attachment 8374851 [details] [diff] [review]
Remove element using iterator while looping in ArrayList (r=wesj)

Top crasher in Fx29 and Fx30. Apparently caused by bug 881861.
Attachment #8374851 - Flags: review?(wjohnston)
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 969743
Comment on attachment 8374851 [details] [diff] [review]
Remove element using iterator while looping in ArrayList (r=wesj)

Review of attachment 8374851 [details] [diff] [review]:
-----------------------------------------------------------------

I think you're right. This is simpler. Lets just use it. Flipping the dup around....
Attachment #8374851 - Flags: review?(wjohnston) → review+
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Duplicate of this bug: 969743
https://hg.mozilla.org/mozilla-central/rev/7273e402c9e6
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 30
Comment on attachment 8374851 [details] [diff] [review]
Remove element using iterator while looping in ArrayList (r=wesj)

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 881861, which I'm also noming for uplift
User impact if declined: Crash
Testing completed (on m-c, etc.): Landed on mc last week.
Risk to taking this patch (and alternatives if risky): This is pretty simple and very low risk. Alternatively here is to not uplift 881861
String or IDL/UUID changes made by this patch: none.
Attachment #8374851 - Flags: approval-mozilla-beta?
Attachment #8374851 - Flags: approval-mozilla-aurora?
Attachment #8374851 - Flags: approval-mozilla-beta?
Attachment #8374851 - Flags: approval-mozilla-beta+
Attachment #8374851 - Flags: approval-mozilla-aurora?
Attachment #8374851 - Flags: approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.