Closed Bug 971825 Opened 6 years ago Closed 6 years ago

"Undo" link after restoring defaults should be a button

Categories

(Firefox :: Toolbars and Customization, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 30
Tracking Status
firefox29 --- verified
firefox30 --- verified

People

(Reporter: dao, Assigned: jaws)

References

(Blocks 1 open bug)

Details

(Whiteboard: [Australis:P3])

Attachments

(2 files)

Reasoning in bug 970511 comment 18.

(In reply to Jared Wein [:jaws] from comment #19)
> It's consistency with the New Tab Page thumbnails.

That's not reason enough for this to be a link. For one, as I've explained, there are places where we've randomly used links instead of buttons for no reason, and we don't want new UI to be consistent with a mess we've created elsewhere. Secondly, there may actually be a valid reason for the New Tab page to use a link, like the fact that it's inside a box along with the "Tumbnail removed" text where a button may look strange, but that reason won't necessarily translate to about:customizing.
Jared, please take care of this by either making Undo a button or confirming that there's a good reason for it to be a link besides consistency with other unrelated UI. Thanks.
Assignee: nobody → jaws
Stephen, this is what it would look like with a button instead of the Undo link. What do you think?
Attachment #8375122 - Flags: ui-review?(shorlander)
I agree that a button is the proper affordance to use here. 

We could have a whole debate about the use of links for secondary commands or for things with minor consequences, but this probably isn't the place ;)

Thanks!
Attached patch PatchSplinter Review
Attachment #8375673 - Flags: review?(dao)
Status: NEW → ASSIGNED
Attachment #8375673 - Flags: review?(dao) → review+
Comment on attachment 8375673 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): change in design req. for bug 970511
User impact if declined: change in design between 29 and 30
Testing completed (on m-c, etc.): local, simple change
Risk to taking this patch (and alternatives if risky): none
String or IDL/UUID changes made by this patch: none
Attachment #8375673 - Flags: approval-mozilla-aurora?
I will approve it once it reached m-c.
https://hg.mozilla.org/mozilla-central/rev/8e9dfd4baac1
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 30
Attachment #8375673 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Whiteboard: [Australis:P3]
QA Contact: cornel.ionce
Verified as fixed on Windows 7 64 bit, Ubuntu 12.04 and Mac OS X 10.9 using latest Nightly (build ID: 20140313030202) and latest Aurora (build ID: 20140313004000). 
"Undo" is now displayed as a button instead of a link.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.