Note: There are a few cases of duplicates in user autocompletion which are being worked on.

spidermonkey_build.py looks for gcc in two different places

RESOLVED INVALID

Status

Release Engineering
General Automation
RESOLVED INVALID
4 years ago
3 years ago

People

(Reporter: sfink, Assigned: sfink)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
The in-tree mozconfig expects gcc to be unpacked from tooltool into $topsrcdir/gcc. spidermonkey_build.py wants it in /tools/gcc. I'm not sure why my testing for bug 961314 didn't catch this.
(Assignee)

Comment 1

4 years ago
Created attachment 8374975 [details] [diff] [review]
Put gcc in both places it is looked for

Temporary fix: just put it both places. The $topsrcdir location seems weird to me, especially if you're going to compile other stuff. Then again, it doesn't require privileged access to put it into /tools, so maybe it's better after all. I'd like to land this now to fix the immediate problem, then argue out which one is right.
Attachment #8374975 - Flags: review?(aki)
(Assignee)

Updated

4 years ago
Blocks: 961314

Comment 2

4 years ago
Comment on attachment 8374975 [details] [diff] [review]
Put gcc in both places it is looked for

Yuk.
Mozconfig change? Softlink?
Attachment #8374975 - Flags: review?(aki) → review+
Duplicate of this bug: 971871

Comment 4

4 years ago
The merge changed the permission of the file to 644:
http://hg.mozilla.org/build/mozharness/rev/12453b8563f7

I pushed a fix to the file permissions:
http://hg.mozilla.org/build/mozharness/rev/a61497549829
As few paid sheriffs as we have this week, it's going to be Amateur Hour before long, so I've hidden it on m-i, m-c, b-i, f-t and try.
(Assignee)

Comment 6

4 years ago
Backing this fix out. I don't think I'll need it anymore at all.

http://hg.mozilla.org/build/mozharness/rev/8a6b8e3a949e - backed out d803d2c04be4
http://hg.mozilla.org/build/mozharness/rev/22a7de23d1db - backed out bad0aa60db7a
(Assignee)

Updated

3 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.