Closed Bug 971931 Opened 7 years ago Closed 7 years ago

[OPEN C_1.3] [Contacts] Cannot see buttons when trying to import Google contacts

Categories

(Web Compatibility :: Mobile, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 980635

People

(Reporter: marcia, Assigned: karlcow)

References

()

Details

(Whiteboard: [mwcdemo2014])

Attachments

(3 files)

Attached image 2014-02-12-11-59-27.png
Open C while running with the latest base image and:

Gaia      bf79fe1fbc59838c13899dd39748875ee4086ec3
Gecko     b71e4b8dbfa4dc028dd5a137d1d521b8fa4d510a
BuildID   20140210112447
Version   28.0
ro.build.version.incremental=eng.duanxiaodong.20140129.175912
ro.build.date=Wed Jan 29 17:59:23 CST 2014 

STR:
1. Open the contacts app and try to import contacts
2. Receive the attached screenshot
Unfortunately we cannot do anything is a Google issue
I am also able to replicate this issue on the ZTE Open C and on the Keon v1.3 (screenshot1). 

ZTE Open (Ebay) and LG Fireweb v1.1 were not affected by this issue (no confirmation page) so there is definitely something different happening.

I understand that we are not able to fix Google’s bugs, but do we know any contacts at Google who may be able to help fixing this issue? 

The “Import Contacts” feature is part of the First Time Use Experience, and every user that chooses to import Google contacts will encounter this issue on this device. This is not how we would like their First Run experience to be - I believe this will have enough visibility to warrant a discussion how we can push to resolve this.

This bug makes the confirmation screen look confusing, having only a “Cancel” button to press. Dragging the screen to the left reveals the “Accept” button (screenshot2) but the average first-time smartphone user would not think of that. Tapping the “Cancel” button instead, sends the user to a blank screen.

It seems like a simple visual glitch on the CSS code?

Please let me know if there is anything I can do to help.

Thanks!!
- Ralph
Attached image screenshot1.png
Screenshot1 - Confirmation page with "Accept" button hidden
Attached image screenshot2.png
Screenshot2 - Confirmation page with "Accept" button showing after dragging the screen to the side.
Karl, do you have any contacts over at google that could help slide the "accept" button over into the visable space on firefox phones.   I'm pretty sure that lots of people might be giving up on importing contacts from gmail on firefox phones since the only button they see is "cancel",  if they don't bother to scroll on the set up screen.   makes sense to scroll on webpages, but not on something that appears more like a setup application.
(In reply to chris hofmann from comment #5)
> Karl, do you have any contacts over at google that could help slide the
> "accept" button over into the visable space on firefox phones.   I'm pretty
> sure that lots of people might be giving up on importing contacts from gmail
> on firefox phones since the only button they see is "cancel",  if they don't
> bother to scroll on the set up screen.   makes sense to scroll on webpages,
> but not on something that appears more like a setup application.

NI'ing Karl here to see if he can help escalate.
Flags: needinfo?(kdubost)
Marcia, Chris,

Do you know if the user agent when the app is contacting https://accounts.google.com/ is the usual
"Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0"?
Flags: needinfo?(mozillamarcia.knous)
Assignee: nobody → kdubost
Status: NEW → ASSIGNED
Component: Gaia::Contacts → Mobile
Flags: needinfo?(kdubost)
Product: Firefox OS → Tech Evangelism
OK after digging a bit, this is a duplicate.
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Flags: needinfo?(mozillamarcia.knous)
Resolution: --- → DUPLICATE
Duplicate of bug: 980635
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.