'Payment Cancelled' message is displayed after 'Payment Complete' message

RESOLVED FIXED

Status

Marketplace
Payments/Refunds
P2
normal
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: krupa, Unassigned)

Tracking

Other
Android
Points:
---
Dependency tree / graph

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Android: 4.0.3
firefox 29.0a2

steps to reproduce:
1. Load marketplace-dev.allizom.org on Firefox mobile aurora
2. Search for paid apps
3. Start the purchase of a paid app
4. Sign in using persona
5. Enter PIN
6. Make the purchase using a credit card

actual behavior:
We see 'Payment Complete' screen after which we see the 'Payment Cancelled' message on marketplace.

logcat shows:
02-12 17:14:24.728 E/GeckoConsole(12827): [req] GETing https://marketplace.allizom.org/api/v1/webpay/status/fb7d52ed2b89406bcdc850633cb391fc/?_user=blah-blah&dev=android&device=mobile&lang=en-US&region=us
02-12 17:14:24.868 E/GeckoConsole(12827): [req] Request failed: GET 0
02-12 17:14:24.868 E/GeckoConsole(12827): [JavaScript Error: "[payments] Error fetching payment status:  pricetier6  0"]
02-12 17:14:24.868 E/GeckoConsole(12827): [buttons] Purchase flow rejected for pricetier6
02-12 17:14:24.873 E/GeckoConsole(12827): [buttons] Unsuccessful install for pricetier6
02-12 17:14:24.873 E/GeckoConsole(12827): [payments] Clearing payment timers for:  pricetier6
(Reporter)

Comment 1

4 years ago
Created attachment 8375217 [details]
logs.txt
(Reporter)

Comment 2

4 years ago
Note that the app can be bought after clicking the buy button.

Comment 3

4 years ago
Note: that we see Request failed: GET 0, is this the same as.
Depends on: 970641
(Reporter)

Comment 4

4 years ago
02-12 17:13:07.313 E/GeckoConsole(12827): [cli] mozPaymentProvider.sendSilentSms? undefined
02-12 17:13:07.313 E/GeckoConsole(12827): [pay] flow= lobby
02-12 17:13:07.318 E/GeckoConsole(12827): [id] watch: loggedInUser string krupa.mkm@gmail.com
02-12 17:13:07.318 E/GeckoConsole(12827): [pin] requesting focus on pin
02-12 17:13:07.318 E/GeckoConsole(12827): [cli] has nothing toShow
02-12 17:13:07.318 E/GeckoConsole(12827): [cli] Focusing pin
02-12 17:13:07.318 E/GeckoConsole(12827): [pin] focused
02-12 17:13:07.328 E/GeckoConsole(12827): [JavaScript Warning: "Use of getPreventDefault() is deprecated.  Use defaultPrevented instead." {file: "https://marketplace-cdn.allizom.org/mozpay/media/js/pay-min.js?build=0563600-52f5564e" line: 2}]

I also see something about silentSMS being undefined but I don't know if that is relevant.

Updated

4 years ago
Priority: -- → P2

Comment 5

4 years ago
This is quite old and I can't reproduce. I'm going to close and as we test Android let's see if it occurs.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.