Closed Bug 972134 Opened 6 years ago Closed 3 years ago

Stop exposing the -moz-resolution media fragment to the web

Categories

(Core :: ImageLib, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1118926

People

(Reporter: ehsan, Unassigned)

References

Details

Please see bug 419588 comment 46.  We should expose this media fragment to chrome callers only for now.
Blocks: 419588
Boy do I wish we could just get rid of -moz-resolution entirely and take another approach. =\
How does this relate to e.g. image-resolution[1]? Couldn't find any doc for -moz-resolution …

[1] http://www.w3.org/TR/css3-images/#the-image-resolution
(In reply to comment #2)
> How does this relate to e.g. image-resolution[1]? Couldn't find any doc for
> -moz-resolution …
> 
> [1] http://www.w3.org/TR/css3-images/#the-image-resolution

They're not related.  -moz-resolution was added in bug 419588.  I don't think that it's documented.
Hi guys, I'm trying to write an add-on where I need to get the different sizes of the icon on the exe.

So what I do right now (on winXP) is:

var foxexe = FileUtils.getFile("XREExeF", []);
var iconurl = "moz-icon:" + Services.io.newFileURI(foxexe).spec;

which gives:
* moz-icon:file:///C:/Program%20Files/Aurora/firefox.exe?size=16
* moz-icon:file:///C:/Program%20Files/Aurora/firefox.exe?size=32

but the size=16 one is very blurry, the size=32 one is good. could i use -moz-resolution to help me out here?

i couldnt find any documentation anywhere

thanks guys
Not really no. We don't have any built in ways to query the available sizes in a particular file. You could either iterate through a bunch of sizes and drawn them on canvases to get sizes, or you could write a parser in js (these files are pretty simple to read).
Thanks for the super fast reply man! I don't understand what's going on three. If I use drawImage to canvas with resize parameters it will come out really nicely anti-aliased on resize?

I don't understand the need to iterate through the sizes, then next I don't know how to do that. :(

I'm not sure what a parser is.

Are you saying I can use moz-resolution but before I do I have to know the sizes? I thought a png or ico was only one size.

If you can please help me answer these questions that would be so great!!
Also could you tell me how to use moz-resoloution please. Like what it does. Maybe I can get it to work. :)
(In reply to Seth Fowler [:seth] from comment #1)
> Boy do I wish we could just get rid of -moz-resolution entirely and take
> another approach. =\

As far as I can tell only three Firefox UI files and one add-on use it. B2G/gaia do not. Seems about as good a position we could wish for if we want to remove it.
Depends on: 1118926
Status: NEW → RESOLVED
Closed: 3 years ago
No longer depends on: 1118926
Resolution: --- → DUPLICATE
Duplicate of bug: 1118926
You need to log in before you can comment on or make changes to this bug.