Closed Bug 972144 Opened 6 years ago Closed 6 years ago

Requesting "sync now" while identity manager is still initializing causes error notification to appear.

Categories

(Firefox :: Sync, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 30
Tracking Status
firefox29 + fixed
firefox30 --- verified

People

(Reporter: markh, Assigned: markh)

References

Details

Attachments

(1 file)

STR:
* After restarting Fx with a user configured for Sync, select "Sync Now"

Actual:
* A yellow notification box tells you that sync failed with an unknown error, and displays a button where you can open sync prefs.

Expected:
* No error notification is displayed, and sync starts ASAP.

Note that bug 972129 is to ensure the sync starts ASAP - this bug is just about the error notification.
Blocks: 969593
OS: Windows 7 → All
Hardware: x86_64 → All
Simple patch that causes browser-syncui to ignore LOGIN_FAILED_NOT_READY errors.
Assignee: nobody → mhammond
Status: NEW → ASSIGNED
Attachment #8375257 - Flags: review?(ttaubert)
Comment on attachment 8375257 [details] [diff] [review]
0002-Bug-972144-don-t-show-error-notification-for-LOGIN_F.patch

Review of attachment 8375257 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM
Attachment #8375257 - Flags: review?(ttaubert) → review+
https://hg.mozilla.org/mozilla-central/rev/56c33addbd2f
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 30
Verified fixed on latest Nightly. Confirmed that it still affects Fx29.
Status: RESOLVED → VERIFIED
Comment on attachment 8375257 [details] [diff] [review]
0002-Bug-972144-don-t-show-error-notification-for-LOGIN_F.patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): FxA Sync
User impact if declined: Sync may report errors when there aren't any
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): None
String or IDL/UUID changes made by this patch: None
Attachment #8375257 - Flags: approval-mozilla-aurora?
Attachment #8375257 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.