Closed Bug 972196 Opened 6 years ago Closed 5 years ago

Ensure FxA-based sync continues working immediately after Firefox Refresh

Categories

(Firefox :: Firefox Accounts, defect)

29 Branch
defect
Not set
Points:
1

Tracking

()

VERIFIED FIXED
Firefox 37
Iteration:
37.3 - 12 Jan
Tracking Status
firefox36 + verified
firefox37 + verified

People

(Reporter: rnewman, Assigned: markh)

References

(Depends on 1 open bug, )

Details

Attachments

(1 file)

As I understand it, Reset Firefox will blow away your FxA credentials. Reset users are perhaps most likely to have forgotten their credentials. This might be worth addressing.
What happens with current Sync?

Doesn't feel like a case we need to worry about too much offhand.
Current Sync stores its credentials in pwmgr, so they'll still be there after the reset (assuming Reset doesn't blow away all of Sync's prefs, which it might). FxA stores them in a file in the profile, which will be lost.

I don't regard current Sync sucking as much of a defense when we plan 10x the users.

This is not a case we need to worry about now. It's a case we need to worry about when 29 is six months old and is offering to reset idle users' profiles.

Might be worth half an hour to figure out what happens and if there's anything we can preserve to make things transparently work.
Mark, can you test what happens here, and if it's bad, see if there anything simple we can do to improve it?
Flags: needinfo?(mhammond)
Flags: firefox-backlog+
It turns out that copying signedInUser.json is enough to keep sync working after a reset \o/
Attachment #8537637 - Flags: review?(MattN+bmo)
Assignee: nobody → mhammond
Status: NEW → ASSIGNED
Points: --- → 1
Flags: needinfo?(mhammond) → qe-verify+
Summary: Consider interaction between FxA and Reset Firefox → Ensure FxA-based sync continues working immediately after Firefox Refresh
Iteration: --- → 37.2
Iteration: 37.2 → 37.3
Comment on attachment 8537637 [details] [diff] [review]
0001-Bug-972196-copy-signedInUser.json-on-Firefox-reset-t.patch

Review of attachment 8537637 [details] [diff] [review]:
-----------------------------------------------------------------

Sorry for the delay
Attachment #8537637 - Flags: review?(MattN+bmo) → review+
https://hg.mozilla.org/mozilla-central/rev/379e016a9f05
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla37
Comment on attachment 8537637 [details] [diff] [review]
0001-Bug-972196-copy-signedInUser.json-on-Firefox-reset-t.patch

Approval Request Comment
[Feature/regressing bug #]: N/A
[User impact if declined]: Sync breaks after Fx Reset 
[Describe test coverage new/current, TBPL]: No new tests, landed on m-c
[Risks and why]: Low
[String/UUID change made/needed]: None
Attachment #8537637 - Flags: approval-mozilla-aurora?
Attachment #8537637 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Reproduced the initial issue on Firefox 32 RC and verified that using Firefox 36beta1 build 2 and Latest Aurora across platforms, I am still logged in after I refresh Firefox.
Status: RESOLVED → VERIFIED
Duplicate of this bug: 1129485
Depends on: 1311091
Duplicate of this bug: 754933
Depends on: 1395332
Product: Core → Firefox
Target Milestone: mozilla37 → Firefox 37
You need to log in before you can comment on or make changes to this bug.