[tarako] flash of gradient then black then white then black when switching gallery<->camera

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: dietrich, Assigned: dkuo)

Tracking

unspecified
x86
Mac OS X

Firefox Tracking Flags

(blocking-b2g:1.3T+, b2g-v1.3T fixed)

Details

Attachments

(1 attachment)

46 bytes, text/x-github-pull-request
alive
: review+
Details | Review | Splinter Review
(Reporter)

Description

5 years ago
STR:

1. switch between gallery and camera in either direction

You'll see for about 300-500ms each...

a gradient-ish screen
then an all black screen
then an all white screen
then an all black screen
then the app contents become visible
(Reporter)

Updated

5 years ago
blocking-b2g: --- → 1.3T?
blocking-b2g: 1.3T? → 1.3T+
already 1.3T+, remove [tarako] whiteboard
Whiteboard: [tarako]
Brian, can you check if that still happens?
Flags: needinfo?(brhuang)
Keywords: qawanted
I use latest build to test. It still happens.

http://youtu.be/1JGyZxpV8ro
Flags: needinfo?(brhuang)
Hema, can you please help find an assignee here who can help investigate ?
Flags: needinfo?(hkoka)

Comment 5

5 years ago
Is this only happening on Tarako for latest build? If it is Tarako, only can we get some devices to test this on.

Dominic,

Can you help with the initial investigation (you may probably already have the Tarako device in Taipei)?

CC'ing David too

Thanks
Hema
Flags: needinfo?(dkuo)

Updated

5 years ago
Flags: needinfo?(hkoka)
Keywords: qawanted
(Assignee)

Comment 6

5 years ago
Taking it.
Assignee: nobody → dkuo
Flags: needinfo?(dkuo)
(Assignee)

Comment 7

5 years ago
I took some tests on tarako and found this might be a general issue on launching web activities, probably the background color of the target app is white then cause this issue. I am trying to modify the background color and see if we can fix it easily.
(Assignee)

Comment 8

5 years ago
Okay, looks like changing the background-color of camera or gallery won't help here, I will see if the white screen is the background before launching an app or activity.
hi Dominic, wonder if you have further update to this one? or do you need some help here as you are working on some music bugs? thanks
Flags: needinfo?(dkuo)
(Assignee)

Comment 10

5 years ago
(In reply to Joe Cheng [:jcheng] from comment #9)
> hi Dominic, wonder if you have further update to this one? or do you need
> some help here as you are working on some music bugs? thanks

Sorry about not updating the status, I just finished a 1.3t blocker yesterday and moving to this bug, I will work on this issue today and if I could not find the root cause or no confidence of fixing this, I will ask for help.(Actually not just music bugs I am also working on some other blockers, like ringtones, audio channel or the media playback in system...)
(Assignee)

Comment 11

5 years ago
After investigated for a while I couldn't find where was the white screen occurred, this might be the gap between the app window transitionend and the splash screen, which gaia is unable to pre-render some black screen to prevent the user seeing the noticeable white screen, I need some help here and wonder if gecko devs can help us.

CJ, would you please find someone to help on this issue? thanks. Note that I could only reproduced this on tarako so probably caused by slow devices.
Assignee: dkuo → nobody
Flags: needinfo?(dkuo) → needinfo?(cku)

Comment 12

5 years ago
chiajung,
1.3T+ issue, please take it as highest priority

IRC chat log:
:CJKu:. dkuo, ok
.:CJKu:. dkuo, repro rate? 
.:CJKu:. 100%?
<dkuo> CJKu: yes
.:CJKu:. dkuo, good, thank.
<dkuo> CJKu: 嗯嗯,另外我有發現一點好像是因為gallery跟camera都是full screen的app,可能有關係
Flags: needinfo?(pchang)
Flags: needinfo?(cku)
Flags: needinfo?(chung)
I found tarako devices always kill old app and keep new one, which seems related to the problem. After discuss with :alive, it seems the default color of iFrame in system.css
Flags: needinfo?(pchang)
Flags: needinfo?(chung)
(Assignee)

Comment 14

5 years ago
(In reply to Chiajung Hung [:chiajung] from comment #13)
> I found tarako devices always kill old app and keep new one, which seems
> related to the problem. After discuss with :alive, it seems the default
> color of iFrame in system.css

Thanks Chiajung, yes you are correct, the white screen is the default color of the iframe, and seems that when the previous app is killed(maybe by LMK) while the system is launching the new app, we could see the white iframe which probably was behind the previous iframe.

And the patch should be simply changing the background color from white to black, will send a patch later.
Assignee: nobody → dkuo
(Assignee)

Updated

5 years ago
Component: Gaia::Gallery → Gaia::System::Window Mgmt
(Assignee)

Comment 15

5 years ago
Created attachment 8396213 [details] [review]
v1.3t patch

Alive, since you knew this issue and familiar with system app, would you please review the patch? thanks.

Also do you think 1.4 or master branches need this modification? though this might only happen on low-end devices, like tarako.
Attachment #8396213 - Flags: review?(alive)
Comment on attachment 8396213 [details] [review]
v1.3t patch

I wonder if someday gallery/camera background becomes white or other light color we will have bug: flash of gradient then white then black then white when switching gallery<->camera.
Please try to set transparent color to the iframe, but if that doesn't work, go with this patch.
Attachment #8396213 - Flags: review?(alive) → review+
Ying, are you okay to uplift it? thanks!

--
Keven
Flags: needinfo?(ying.xu)
(Assignee)

Comment 18

5 years ago
(In reply to Alive Kuo [:alive][NEEDINFO!][God bless Taiwan.] from comment #16)
> Comment on attachment 8396213 [details] [review]
> v1.3t patch
> 
> I wonder if someday gallery/camera background becomes white or other light
> color we will have bug: flash of gradient then white then black then white
> when switching gallery<->camera.
> Please try to set transparent color to the iframe, but if that doesn't work,
> go with this patch.

Sounds reasonable and is worth to try, I will use transparent color to test on tarako again, see if we gat better result on this, thanks.

And Ying you probably can wait for my test result to see "black" or "transparent" has better ux here.
I don't understand that status of this bug. Fixed? Landed?
Flags: needinfo?(dkuo)
It is landed by ting.xu.

--
Keven
Please, when landing gaia patches, mark the bug as fixed. And also set the status-b2g-v1.3T flag to 'fixed'.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
status-b2g-v1.3T: --- → fixed
Resolution: --- → FIXED
(Assignee)

Comment 23

5 years ago
(In reply to Tim Guan-tin Chien [:timdream] (MoCo-TPE) (please ni?) from comment #20)
> I don't understand that status of this bug. Fixed? Landed?

The 1.3T PR was merged by partner but other branches, Alive suggested us to try transparent instead of black and we should test it then decide which to land on the other branches.
Flags: needinfo?(dkuo)

Updated

5 years ago
Flags: needinfo?(ying.xu)
You need to log in before you can comment on or make changes to this bug.