Closed Bug 972251 Opened 6 years ago Closed 6 years ago

[NFC] image sharing transfer failed before bluetooth pairing message

Categories

(Firefox OS Graveyard :: NFC, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 964693

People

(Reporter: wachen, Unassigned)

References

Details

Attachments

(1 file)

log
219.96 KB, text/x-vhdl
Details
today's mako master build from twci (any other build should be the same)

STR:
0. NFC enabled
1. launch gallery
2. open a picture
3. tap with another phone
4. slide to share

Expected result:
Transfer done.

Actual result:
It failed before bt pairing, and bt confirmation dialect came out later
blocking-b2g: --- → 1.4?
Blocks: 894320
John, may you please check what is happened?
Flags: needinfo?(johu)
Ken,

I had met this before. This is originated from NFC handover manager calls pair before sending the file. It shouldn't do that. Once we don't do pairing, it is gone. We had opened a bug for this case, bug 964672. Bug 964672 shows this issue had been fixed. If it still happens, we need to reopen that one or keep this one.

BTW, I cannot check this out. It is related to NFC handover manager and BT.
Flags: needinfo?(johu)
Sid, can you please check this?
Flags: needinfo?(psiddh)
Hi Ken,

Yes as per the recent changes, nfc_manager shouldn't call 'pair' before doing a 'sendFile'.
So 'pairing message' not being shown is no longer an issue. 
[See bug: https://bugzilla.mozilla.org/show_bug.cgi?id=964672  comment#4 and https://bugzilla.mozilla.org/show_bug.cgi?id=972188 comment#1].

However, we are still not able to perform 'sendfile' (transferring of image file). After analyzing the logs,this issue is possibly due to Bug# 964693]
Flags: needinfo?(psiddh)
Attached file log
Attaching the sendFile logs and requesting Eric to take a quick look of the logs from bluetooth perspective.
Flags: needinfo?(echou)
Whiteboard: [FT:RIL]
Just tried with flashing the latest build to my n4 and I can confirm it's the same issue as bug 964693.
Flags: needinfo?(echou)
blocking-b2g: 1.4? → ---
Blocks: b2g-NFC-2.0
No longer blocks: b2g-NFC-2.0
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 964693
Whiteboard: [FT:RIL]
You need to log in before you can comment on or make changes to this bug.