Closed Bug 972268 Opened 8 years ago Closed 3 years ago

[Sora][Browser]Interface display abnormally,Pictures and characters on the screen do not overlap

Categories

(Web Compatibility :: Mobile, defect, P5)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:-)

RESOLVED WONTFIX
blocking-b2g -

People

(Reporter: sync-1, Unassigned)

References

()

Details

(Whiteboard: [country-cn] [clientsniff][contactready])

Attachments

(3 files)

Mozilla build ID: 20140208004002
 
 Created an attachment (id=631362)
 picture
 
 DEFECT DESCRIPTION:
 Interface display abnormally,
 REPRODUCING PROCEDURES:
 1.lanuch"http://news.youku.com/qihou2012/index"
 2.look at the interface,Some pictures cover some characters---ko
 EXPECTED BEHAVIOUR:
 Pictures and characters on the screen do not overlap
 ASSOCIATE SPECIFICATION:
 
 TEST PLAN REFERENCE:
 
 TOOLS AND PLATFORMS USED:
 
 USER IMPACT:
 telephone:021-51790200 (7035)
 Mail:chunmei.zhang.com
 Skpye: Chunmei.zhang5 
 Microsoft Lync:chunmei.zhang.com 
 REPRODUCING RATE:
 100%
 
 For FT PR, Please list reference mobile's behavior:
Attached image picture
Component: Gaia::Browser → Mobile
Product: Firefox OS → Tech Evangelism
It seems like a flash problem. Gecko can't parse the <object> element on the web page.
Created an attachment (id=636042)
 Analyze web page on firefox
Created an attachment (id=636042)
 Analyze web page on firefox
Created an attachment (id=636042)
 Analyze web page on firefox
Created an attachment (id=636033)
 Chrome browser
Created an attachment (id=636033)
 Chrome browser
Attached image Chrome browser
Created an attachment (id=636033)
 Chrome browser
blocking-b2g: --- → 1.3?
Not blocking - this is a TE issue, outside of Mozilla's direct control.
blocking-b2g: 1.3? → -
(In reply to comment #4)
 > Comment from Mozilla:Not blocking - this is a TE issue, outside of Mozilla's
 > direct control.
 > 
 
 What's TE?
TE == Tech Evangelism. aka Web Compatibility issues that is not related to Mozilla code but to development decisions by the Web site. Of the site might need to be reached out so they can fix the issue on their side.

See https://wiki.mozilla.org/Compatibility/Mobile
OS: All → Gonk (Firefox OS)
Hardware: All → ARM
Whiteboard: [country-cn]
Assignee: nobody → miket
At [1], Youku._IsHtml5 is set to false, so they try to load a flash video with swfobject.js. Ultimately we need to figure out why _IsHTML5 is false and hopefully getting them to set it to true will serve us HTML5 video which we can handle.

The reason the <object>/<embed> fails to be placed in the document is due to the swfobject library (they're using 2.1) and the sites failure to provide fallback content.

In the embedSWF method, there are two conditions--both of which rely on a minimum flash version check (the "q" argument). In order to determine this "q" is passed to the function "c".

This function compares the major/min/release numbers from the installed version of flash to the minimum version passed as "q". For this site, they're expecting flash player version "9.0.0" or greater. Now, the reason this all fails is because the major/min/release ("AC" variable) is initialized to [0,0,0]. If you can pass the if (typeof navigator.plugins != undefined && typeof navigator.plugins['Shockwave Flash'] == "object") condition, "AC" is updated---but Firefox OS doesn't support flash so that condition is false.

So any call to "c" will return false as 0 < 9. This is expected behavior, IMO.

Juding by the behavior of [3] (from the swfobject testsuite) in Firefox OS, swfobject provides a way to show fallback/non-flash content. This is likely what [4] is all about--inserting an image in the player container that links elsewhere. Unfortunately that's predicated on a "if((/(iPhone|iPad|iPod)/i.test(navigator.userAgent))){" condition.

See https://code.google.com/p/swfobject/wiki/documentation ("How to embed Flash Player content using SWFObject dynamic publishing") which explains how the dynamic insertion works with alternative content--essentially they can put an image that links elsewhere inside the container where the flash video will be added (if supported).

[1] https://gist.github.com/miketaylr/9119551#file-inline-js-L5
[2] http://api.youku.com/api/js/swfobject.js
[3] http://www.bobbyvandersluis.com/swfobject/testsuite_2_2/test_dynamic.html
[4] https://gist.github.com/miketaylr/9119551#file-inline-js-L49-L53
Seems like Youku._IsHtml5 is always false, no matter the browser.
Whiteboard: [country-cn] → [country-cn] [clientsniff][contactready]
Assignee: miket → nobody
Assignee: nobody → yliu
Status: NEW → ASSIGNED
link all Fire C (codename: Sora) bugs to a meta one.
Priority: P2 → P5
The Firefox OS project is not active anymore.
Assignee: yliu → nobody
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.