On locked call screen arrows are not the same

RESOLVED FIXED in Firefox OS v1.4

Status

Firefox OS
Gaia::Dialer
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: zlati.pehlivanov, Assigned: snowmantw)

Tracking

unspecified
2.0 S2 (23may)
Other
Gonk (Firefox OS)

Firefox Tracking Flags

(tracking-b2g:backlog, b2g-v1.4 fixed, b2g-v2.0 fixed)

Details

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 (Beta/Release)
Build ID: 20140127194636

Steps to reproduce:

Receive a call in a locked screen state


Actual results:

the interface appeared for choosing to pickup or hang the call. the right icon is smaller then the left one.


Expected results:

the icons should be the same
(Reporter)

Comment 1

4 years ago
bug appears in 1.4 nightly build 
nightly-images-peak-master-2014-02-13.Gecko-90b607e.Gaia-7800373
Component: General → Gaia::Dialer
OS: All → Gonk (Firefox OS)
Hardware: All → Other
(Reporter)

Comment 2

4 years ago
Created attachment 8375684 [details]
2014-02-13-21-10-28.png
Are you still seeing this? I can't reproduce on a Peak.
Flags: needinfo?(zlati.pehlivanov)
(Reporter)

Comment 4

4 years ago
Yes, even in 1.5, the build number I have installed is 20140329064833
Flags: needinfo?(zlati.pehlivanov)
(Reporter)

Comment 5

4 years ago
You should be in a locked state
Ah right, I'm seeing it. Greg: this looks like an issue on all high density screens, could you look into it?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(gweng)
(Assignee)

Comment 7

4 years ago
It's a weird case that two arrows are not the same.
I'll check if the ordinary LockScreen has the same issue first (because the slider is using the same code).
Flags: needinfo?(gweng)
(Reporter)

Comment 8

4 years ago
the ordinary LockScreen is ok

Updated

4 years ago
Assignee: nobody → gweng
(Assignee)

Comment 9

4 years ago
Hmm...I've confirmed this on Nexus 4. The most strange thing is the images, code and style should be the same in these two sliders.

Need info Steve because I need his opinion to debug with the incoming LockScreen.
Flags: needinfo?(schung)
FYI, now that the call screen is a standalone app, you can inspect it with the app manager. If you remove the code that closes the call screen when an entering call is dropped, you can keep it open for as long as you need.
https://github.com/mozilla-b2g/gaia/tree/master/apps/callscreen/style/images
It looks like we missed the 1.5X rarrow.png
Flags: needinfo?(schung)
And 2x…

We're reproducing this on a Peak but from comment 11, this will reproduce on any hi-res device. Asking to block 1.3 if we ship on hi-res devices.

Stephany: Who should have those assets?
blocking-b2g: --- → 1.3?
Flags: needinfo?(swilkes)
Keywords: regressionwindow-wanted
(Assignee)

Comment 13

4 years ago
It's a missing PNG file that already in the System app, but not copied to the dialer app. This was identified last week.

I would make a patch and sent later.
Definitely not a blocker - this a visual glitch fallout, which isn't critical enough to block 1.3 at this point. 1.3 blockers have to be cert issues at this point.
blocking-b2g: 1.3? → backlog
Keywords: regressionwindow-wanted
Given how simple and non risky the patch will be, I think we should ask approval for all branches.
Actually, it's not the case. https://github.com/mozilla-b2g/gaia/tree/bd16a10702e801b717f8848ee7ccc79f781c8f79/apps/system/style/lockscreen/images has no 2x version of those icons…

Comment 17

4 years ago
Flagging Patryk to flag whomever may be needed on visual assets.
Flags: needinfo?(swilkes) → needinfo?(padamczyk)
Amy should be able to provide these.
Flags: needinfo?(padamczyk) → needinfo?(amlee)
Created attachment 8419793 [details]
arrows_x1.5_x2.zip

Hi, 

I've provided pngs of the arrows @1.5 and @2 scale. Let me know if you need anything else!
Flags: needinfo?(amlee)
Created attachment 8420810 [details] [review]
Patch

I have copied the image files into the directory and tested the results with a Nexus 5. @gweng, please review, thanks
Attachment #8420810 - Flags: review?(gweng)
(Assignee)

Comment 21

4 years ago
Comment on attachment 8420810 [details] [review]
Patch

Verified with real device, so here is the r+.
Attachment #8420810 - Flags: review?(gweng) → review+
The patch has landed into master: https://github.com/mozilla-b2g/gaia/commit/18871c73e8cf0e09b4ce5d3fad80809cac7fcb88 with the help of @gweng.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Comment on attachment 8420810 [details] [review]
Patch

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): New lockscreen design
[User impact] if declined: Weird look when receiving phone calls on hidpi phones, see attachment 8375684 [details].
[Testing completed]: Tested by patch author and reviewer in comment 20 and 21.
[Risk to taking this patch] (and alternatives if risky): Just new images that were missing.
[String changes made]: None
Attachment #8420810 - Flags: approval-gaia-v1.4?
Comment on attachment 8420810 [details] [review]
Patch

Taking in release 1.4 for inconsistent UI.
Attachment #8420810 - Flags: approval-gaia-v1.4? → approval-gaia-v1.4+
v1.4: https://github.com/mozilla-b2g/gaia/commit/8806eebe8f1555b1f924166f921ab831a5e3560c
status-b2g-v1.4: --- → fixed
status-b2g-v2.0: --- → fixed
Target Milestone: --- → 2.0 S2 (23may)
(Reporter)

Comment 26

4 years ago
what about v1.5 can this fix be included in the next nightly build for 1.5
1.5 is 2.0 (and master at the moment) so it was fixed 3 days ago with comment 22.
blocking-b2g: backlog → ---
tracking-b2g: --- → backlog
You need to log in before you can comment on or make changes to this bug.