Sync promo footer in bookmarks panel overflows panel content

VERIFIED FIXED in Firefox 29

Status

()

VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: mikedeboer, Assigned: mikedeboer)

Tracking

({regression})

Trunk
Firefox 30
All
Windows 7
regression
Points:
---

Firefox Tracking Flags

(firefox29 verified, firefox30 verified)

Details

(Whiteboard: [Australis:P2])

Attachments

(1 attachment)

(Assignee)

Updated

5 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 1

5 years ago
Stephen, how do I get to see this Sync promo footer?
Flags: needinfo?(shorlander)
check in about:config for browser.syncPromoViewsLeftMap = {"passwords":0,"bookmarks":0,"addons":4}

pump up the number to a positive one (by default it's 5) for the kind of promo you want to see, or just clear user pref.
Open one of these panels.
1. remember password doorhanger
2. star panel
3. add-on install

Note: the promo panel is visible only on profile that didn't setup Sync/FxAccount.
Flags: needinfo?(shorlander)
(Assignee)

Comment 3

5 years ago
Created attachment 8376274 [details] [diff] [review]
Patch v1: adjust margins of panel promo footer on Windows

Thanks Marco! Since you know this in considerable detail, are you the man to review this patch?
I'd be much obliged.
Attachment #8376274 - Flags: review?(mak77)
Comment on attachment 8376274 [details] [diff] [review]
Patch v1: adjust margins of panel promo footer on Windows

Review of attachment 8376274 [details] [diff] [review]:
-----------------------------------------------------------------

it looks good, just in case I verified on other platforms, but the original bug only changed Windows so this should be enough
Attachment #8376274 - Flags: review?(mak77) → review+
(Assignee)

Comment 5

5 years ago
Thanks, Marco!

https://hg.mozilla.org/integration/fx-team/rev/f4cc44651ceb
Whiteboard: [Australis:P2] → [Australis:P2][fixed-in-fx-team]
(Assignee)

Comment 6

5 years ago
Comment on attachment 8376274 [details] [diff] [review]
Patch v1: adjust margins of panel promo footer on Windows

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 961727
User impact if declined: Promo footers in panels will overflow the panel edges, the new Sync promo footer being the most prominent example.
Testing completed (on m-c, etc.): now on fx-team, will land on aurora after m-c is green.
Risk to taking this patch (and alternatives if risky): minor
String or IDL/UUID changes made by this patch: n/a
Attachment #8376274 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/f4cc44651ceb
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P2][fixed-in-fx-team] → [Australis:P2]
Target Milestone: --- → Firefox 30
Attachment #8376274 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Updated

5 years ago
status-firefox29: --- → fixed
status-firefox30: --- → fixed

Updated

5 years ago
QA Contact: cornel.ionce
User Agents:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0
Mozilla/5.0 (Windows NT 6.1; rv:29.0) Gecko/20100101 Firefox/29.0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0
Mozilla/5.0 (Windows NT 6.1; rv:30.0) Gecko/20100101 Firefox/30.0

Confirming the fix on latest Aurora (build ID: 20140313004000) and latest Nightly (build ID: 20140313030202).
Marking this issue verified.
Status: RESOLVED → VERIFIED
status-firefox29: fixed → verified
status-firefox30: fixed → verified
You need to log in before you can comment on or make changes to this bug.