In-memory sync rate limiting

RESOLVED FIXED in Firefox 29

Status

()

RESOLVED FIXED
5 years ago
a year ago

People

(Reporter: rnewman, Assigned: rnewman)

Tracking

Firefox 29
Firefox 30
All
Android
Points:
---

Firefox Tracking Flags

(firefox29 fixed, firefox30 fixed, fennec29+)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
We're back to our old friend Android syncing us twice in a row.

02-13 15:02:33.342 I/FxAccounts( 9595): fennec_rnewman :: FxAccountSchedulePolicy :: Scheduling periodic sync for 28800.
02-13 15:02:33.382 I/FxAccounts( 9595): fennec_rnewman :: FxAccountSyncAdapter :: Sync succeeded.
02-13 15:02:33.382 E/FxAccounts( 9595): fennec_rnewman :: FxAccountSyncAdapter :: Syncing done.
02-13 15:02:33.452 I/FxAccounts( 9595): fennec_rnewman :: FxAccountSyncAdapter :: Syncing FxAccount account named like XXXXXXXXXXXXXXX@XXXXXXX.XXX for authority org.mozilla.fennec_rnewman.db.browser with instance org.mozilla.gecko.fxa.sync.FxAccountSyncAdapter@21651f10.
02-13 15:02:33.452 I/FxAccounts( 9595): fennec_rnewman :: AndroidFxAccount :: $$FxA PII$$: email: rnewman+backoff@mozilla.com


We should keep a flag in the SyncAdapter instance to detect this and skip over it.

And maybe we should also be keeping the AndroidFxAccount instance around...
I see this on pretty much every sync; I've always assumed this is because the Fennec CPs are not notification clean.
(Assignee)

Comment 2

5 years ago
Yup, or another sync request arrived while we were syncing, and Android queues them?

Regardless, especially as we start to listen to multiple CRs, we should take the very cheap step of recognizing when we just finished syncing.
(Assignee)

Comment 3

5 years ago
Created attachment 8376015 [details] [diff] [review]
Patch. v1

This is trivial, so I'm just landing it.
Assignee: nobody → rnewman
Status: NEW → ASSIGNED
Attachment #8376015 - Flags: review+
(Assignee)

Updated

5 years ago
tracking-fennec: --- → 29+
https://hg.mozilla.org/mozilla-central/rev/b72687a8ff19
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 30
(Assignee)

Comment 6

5 years ago
Comment on attachment 8376015 [details] [diff] [review]
Patch. v1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
  FxA Sync.

User impact if declined: 
Testing completed (on m-c, etc.): 
  m-c and QAed.

Risk to taking this patch (and alternatives if risky): 
String or IDL/UUID changes made by this patch:
Attachment #8376015 - Flags: approval-mozilla-aurora?
Attachment #8376015 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 7

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/7ee83a05f105
status-firefox29: --- → fixed
status-firefox30: --- → fixed

Updated

a year ago
Product: Android Background Services → Firefox for Android
You need to log in before you can comment on or make changes to this bug.