Intermittent test_load_same_resource.html | Test timed out.

RESOLVED FIXED in Firefox 32, Firefox OS v1.4

Status

()

RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: mayhemer, Assigned: jwwang)

Tracking

({intermittent-failure})

Trunk
mozilla33
intermittent-failure
Points:
---

Firefox Tracking Flags

(firefox31 wontfix, firefox32 fixed, firefox33 fixed, firefox-esr24 unaffected, firefox-esr31 fixed, b2g-v1.3 unaffected, b2g-v1.3T unaffected, b2g-v1.4 fixed, b2g-v2.0 fixed, b2g-v2.1 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

5 years ago
TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_load_same_resource.html | Test timed out.

https://tbpl.mozilla.org/php/getParsedLog.php?id=34662682&tree=Try
https://tbpl.mozilla.org/php/getParsedLog.php?id=34666609&tree=Try
(Reporter)

Updated

5 years ago
Keywords: intermittent-failure
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 6

5 years ago
(In reply to Honza Bambas (:mayhemer) from comment #0)
> TEST-UNEXPECTED-FAIL |
> /tests/content/media/test/test_load_same_resource.html | Test timed out.
> 
> https://tbpl.mozilla.org/php/getParsedLog.php?id=34662682&tree=Try
> https://tbpl.mozilla.org/php/getParsedLog.php?id=34666609&tree=Try

Hi Honza,
What does the "HTTP cache v2" in the bug title mean? Is this bug related to HTTP or network?
(Reporter)

Comment 7

5 years ago
(In reply to JW Wang[:jwwang] from comment #6)
> (In reply to Honza Bambas (:mayhemer) from comment #0)
> > TEST-UNEXPECTED-FAIL |
> > /tests/content/media/test/test_load_same_resource.html | Test timed out.
> > 
> > https://tbpl.mozilla.org/php/getParsedLog.php?id=34662682&tree=Try
> > https://tbpl.mozilla.org/php/getParsedLog.php?id=34666609&tree=Try
> 
> Hi Honza,
> What does the "HTTP cache v2" in the bug title mean? Is this bug related to
> HTTP or network?

It means it happens only with the new HTTP cache v2 on.  Not with the default preference setting.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Reporter)

Comment 10

5 years ago
We (necko people) believe these test failures are caused by problems in the actual tests rather then in the new http cache, hence moving to the A/V component.
Component: Networking: Cache → Video/Audio
(Reporter)

Comment 11

5 years ago
According comment 8 and 9 this is not reproducible only with the http cache v2.
No longer blocks: 959733
Summary: HTTP cache v2: Intermittent TEST-UNEXPECTED-FAIL | test_load_same_resource.html | Test timed out → Intermittent TEST-UNEXPECTED-FAIL | test_load_same_resource.html | Test timed out
Comment hidden (Treeherder Robot)
(Assignee)

Comment 13

4 years ago
Created attachment 8398354 [details] [diff] [review]
part1_fix_v1.patch

There is only one h264 decoder on b2g emulator. We have to release the decoder of the original element so that the cloned one can start playing. Note that since cloning decoder is an async operation and the cloned elemnt shares media cache with the original, we can't reset 'src' until the decoder is cloned and media cache is completely buffered.

try: https://tbpl.mozilla.org/?tree=Try&rev=8756154da084
Assignee: nobody → jwwang
Status: NEW → ASSIGNED
Attachment #8398354 - Flags: review?(cajbir.bugzilla)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)

Updated

4 years ago
Attachment #8398354 - Flags: review?(cajbir.bugzilla) → review+
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)

Updated

4 years ago
Summary: Intermittent TEST-UNEXPECTED-FAIL | test_load_same_resource.html | Test timed out → Intermittent test_load_same_resource.html | Test timed out.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Updated

4 years ago
Blocks: 1022453
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 143

4 years ago
Created attachment 8458406 [details] [diff] [review]
972826_fix_test_load_same_resource-v2.patch

The v1.patch is less than ideal. Since bug 995090 is fixed, we don't have to wait until the playback reaches the end to delete the decoder of the original element.
Attachment #8398354 - Attachment is obsolete: true
Attachment #8458406 - Flags: review?(cajbir.bugzilla)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)

Updated

4 years ago
Attachment #8458406 - Flags: review?(cajbir.bugzilla) → review+
(Assignee)

Comment 170

4 years ago
Try on B2G: https://tbpl.mozilla.org/?tree=Try&rev=a8da8dd2506d
No failure in test_load_same_resource.html so far.
Keywords: checkin-needed
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
https://hg.mozilla.org/mozilla-central/rev/248b8863ee1c
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla33
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
status-b2g-v1.3: --- → unaffected
status-b2g-v1.3T: --- → unaffected
status-b2g-v1.4: --- → affected
status-b2g-v2.0: --- → affected
status-b2g-v2.1: --- → fixed
status-firefox31: --- → wontfix
status-firefox32: --- → affected
status-firefox33: --- → fixed
status-firefox-esr24: --- → unaffected
status-firefox-esr31: --- → affected
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
You need to log in before you can comment on or make changes to this bug.